XMB is vulnerable to cross-site scripting (XSS) due to inadequate filtering of BBCode…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
XMB is vulnerable to cross-site scripting (XSS) due to inadequate filtering of BBCode input. This bug affects all versions of XMB. All XMB installations must be updated to versions 1.9.12.03 or 1.9.11.16.
Why it matters now
EPSS 0.00817 57th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:xmbforum2:xmb:*:*:*:*:*:*:*:* | 1.9.1 to before 1.9.11.16 | Vulnerable | xmbforum2 |
| cpe:2.3:a:php:php:5.0.0:-:*:*:*:*:*:* | 5.0.0 | Running on | PHP |
| cpe:2.3:a:xmbforum2:xmb:*:*:*:*:*:*:*:* | 1.9.11 to before 1.9.11.16; 1.9.12 to before 1.9.12.03 | Vulnerable | xmbforum2 |
| cpe:2.3:a:php:php:7.0.0:-:*:*:*:*:*:* | 7.0.0 | Running on | PHP |
| cpe:2.3:a:php:php:8.0.0:-:*:*:*:*:*:* | 8.0.0 | Running on | PHP |
- cpe:2.3:a:xmbforum2:xmb:*:*:*:*:*:*:*:* Versions 1.9.1 to before 1.9.11.16 Vulnerable ·xmbforum2
- cpe:2.3:a:php:php:5.0.0:-:*:*:*:*:*:* Versions 5.0.0 Running on ·PHP
- cpe:2.3:a:xmbforum2:xmb:*:*:*:*:*:*:*:* Versions 1.9.11 to before 1.9.11.16; 1.9.12 to before 1.9.12.03 Vulnerable ·xmbforum2
- cpe:2.3:a:php:php:7.0.0:-:*:*:*:*:*:* Versions 7.0.0 Running on ·PHP
- cpe:2.3:a:php:php:8.0.0:-:*:*:*:*:*:* Versions 8.0.0 Running on ·PHP
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-29399
- 2026-10-03 Alias added: GHSA-994w-cp3m-8qh7
References
Sources
- CVE-2021-29399 · CVE Program
- CVE-2021-29399 · NVD
- FIRST EPSS
- GHSA-994w-cp3m-8qh7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences