Read the docs
TI-2021-10148 Aliases CVE-2021-29435GHSA-h8hx-2c5r-32cf

Cross-Site Request Forgery (CSRF) in trestle-auth

Priority LOW 36CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

trestle-auth is an authentication plugin for the Trestle admin framework. A vulnerability in trestle-auth versions 0.4.0 and 0.4.1 allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials. The vulnerability has been fixed in trestle-auth 0.4.2 released to RubyGems.

Why it matters now

EPSS 0.00663 51st percentileScored 2026-11-07
Fix Fixed trestle-auth (TrestleAdmin): 0.4.2trestle-auth (RubyGems): 0.4.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
TrestleAdmintrestle-auth0.4.0 to before 0.4.20.4.2Patch availableCNA
—trestle-auth (RubyGems)0.4.0 to before 0.4.20.4.2Patch availableGHSA-h8hx-2c5r-32cf
  • trestle-auth VendorTrestleAdmin Affected 0.4.0 to before 0.4.2 Fixed in 0.4.2 Patch available CNA
  • trestle-auth (RubyGems) Vendor— Affected 0.4.0 to before 0.4.2 Fixed in 0.4.2 Patch available GHSA-h8hx-2c5r-32cf

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:trestle-auth_project:trestle-auth:0.4.0:*:*:*:*:ruby:*:*0.4.0VulnerableTrestle-auth Project
cpe:2.3:a:trestle-auth_project:trestle-auth:0.4.1:*:*:*:*:ruby:*:*0.4.1VulnerableTrestle-auth Project
  • cpe:2.3:a:trestle-auth_project:trestle-auth:0.4.0:*:*:*:*:ruby:*:* Versions 0.4.0 Vulnerable ·Trestle-auth Project
  • cpe:2.3:a:trestle-auth_project:trestle-auth:0.4.1:*:*:*:*:ruby:*:* Versions 0.4.1 Vulnerable ·Trestle-auth Project

Remediation

  • Fix · CNA trestle-auth (TrestleAdmin) Fixed in 0.4.2
  • Fix · GHSA-h8hx-2c5r-32cf trestle-auth (RubyGems) Fixed in 0.4.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-29435
  2. 2026-10-03 Alias added: GHSA-h8hx-2c5r-32cf
  3. 2026-10-06 EPSS moved to the 50th–90th percentile

References

Sources