Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in @nextcloud/dialogs
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The Nextcloud dialogs library (npm package @nextcloud/dialogs) before 3.1.2 insufficiently escaped text input passed to a toast. If your application displays toasts with user-supplied input, this could lead to a XSS vulnerability. The vulnerability has been patched in version 3.1.2 If you need to display HTML in the toast, explicitly pass the `options.isHTML` config flag.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nextcloud | nextcloud-dialogs | before 3.1.2 | 3.1.2 | Patch available | CNA |
| — | @nextcloud/dialogs (npm) | before 3.1.2 | 3.1.2 | Patch available | GHSA-g3fq-3v3g-mh32 |
- nextcloud-dialogs Vendornextcloud Affected before 3.1.2 Fixed in 3.1.2 Patch available CNA
- @nextcloud/dialogs (npm) Vendor— Affected before 3.1.2 Fixed in 3.1.2 Patch available GHSA-g3fq-3v3g-mh32
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nextcloud\/dialogs_project:nextcloud\/dialogs:*:*:*:*:*:node.js:*:* | before 3.1.2 | Vulnerable | Nextcloud/dialogs Project |
- cpe:2.3:a:nextcloud\/dialogs_project:nextcloud\/dialogs:*:*:*:*:*:node.js:*:* Versions before 3.1.2 Vulnerable ·Nextcloud/dialogs Project
Remediation
- Fix · CNA nextcloud-dialogs (nextcloud) Fixed in 3.1.2
- Fix · GHSA-g3fq-3v3g-mh32 @nextcloud/dialogs (npm) Fixed in 3.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-29438
- 2026-10-03 Alias added: GHSA-g3fq-3v3g-mh32
References
More nextcloud vulnerabilities
- TI-2026-18211 Windmill < 1.615.0 Operator Role Missing Authorization Checks RCE CVSS 4.0HIGH 8.7
- TI-2023-14838 NextCloud Cookbook's pull-checks.yml workflow is vulnerable to OS Command Injection CVSS 3.1HIGH 8.8
- TI-2022-08650 Command Injection in Appointment Emails for Nextcloud Calendar CVSS 3.1CRITICAL 9.8
- TI-2023-20855 Users can delete external storage mount points CVSS 3.1HIGH 7.7
- TI-2023-11091 Nextcloud download permissions can be changed by resharer CVSS 3.1HIGH 7.5
- TI-2023-10624 Nextcloud Server vulnerable to SSRF via filter bypass due to lax checking on IPs CVSS 3.1MEDIUM 5.3
Sources
- CVE-2021-29438 · CVE Program
- CVE-2021-29438 · NVD
- FIRST EPSS
- GHSA-g3fq-3v3g-mh32 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences