Read the docs
TI-2021-10152 Aliases CVE-2021-29439

Plugins can be installed with minimal admin privileges

Priority LOW 37CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.

Summary

The Grav admin plugin prior to version 1.10.11 does not correctly verify caller's privileges. As a consequence, users with the permission `admin.login` can install third-party plugins and their dependencies. By installing the right plugin, an attacker can obtain an arbitrary code execution primitive and elevate their privileges on the instance. The vulnerability has been addressed in version 1.10.11. As a mitigation blocking access to the `/admin` path from untrusted sources will reduce the probability of exploitation.

Why it matters now

EPSS 0.02587 85th percentileScored 2026-11-07
Fix Fixed grav-plugin-admin (getgrav): 1.10.11

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
getgravgrav-plugin-adminbefore 1.10.111.10.11Patch availableCNA
  • grav-plugin-admin Vendorgetgrav Affected before 1.10.11 Fixed in 1.10.11 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:getgrav:grav_admin:*:*:*:*:*:*:*:*before 1.10.11Vulnerablegetgrav
  • cpe:2.3:a:getgrav:grav_admin:*:*:*:*:*:*:*:* Versions before 1.10.11 Vulnerable ·getgrav

Remediation

  • Fix · CNA grav-plugin-admin (getgrav) Fixed in 1.10.11

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-29439

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences