Out-of-bounds read in Mozilla Thunderbird
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
A locally-installed hostile program could send `WM_COPYDATA` messages that Firefox would process incorrectly, leading to an out-of-bounds read. *This bug only affects Firefox on Windows. Other operating systems are unaffected.*. This vulnerability affects Thunderbird < 78.11, Firefox < 89, and Firefox ESR < 78.11.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mozilla | Thunderbird | before 78.11 | 78.11 | Patch available | CNA |
| Mozilla | Firefox | before 89 | 89 | Patch available | CNA |
| Mozilla | Firefox ESR | before 78.11 | 78.11 | Patch available | CNA |
- Thunderbird VendorMozilla Affected before 78.11 Fixed in 78.11 Patch available CNA
- Firefox VendorMozilla Affected before 89 Fixed in 89 Patch available CNA
- Firefox ESR VendorMozilla Affected before 78.11 Fixed in 78.11 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:* | before 89.0 | Vulnerable | Mozilla |
| cpe:2.3:a:mozilla:firefox_esr:*:*:*:*:*:*:*:* | before 78.11 | Vulnerable | Mozilla |
| cpe:2.3:a:mozilla:thunderbird:*:*:*:*:*:*:*:* | before 78.11 | Vulnerable | Mozilla |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:* Versions before 89.0 Vulnerable ·Mozilla
- cpe:2.3:a:mozilla:firefox_esr:*:*:*:*:*:*:*:* Versions before 78.11 Vulnerable ·Mozilla
- cpe:2.3:a:mozilla:thunderbird:*:*:*:*:*:*:*:* Versions before 78.11 Vulnerable ·Mozilla
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · CNA Thunderbird (Mozilla) Fixed in 78.11
- Fix · CNA Firefox (Mozilla) Fixed in 89
- Fix · CNA Firefox ESR (Mozilla) Fixed in 78.11
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Mozilla Firefox 89
5 records Highest priority Priority MEDIUM 1 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2021-10584 Out-of-bounds write in Mozilla ThunderbirdPriority MEDIUM 41
- TI-2021-10582 A malicious website that causes an HTTP Authentication dialog to be spawned could trick…Priority LOW 25
- TI-2021-10579 Firefox for Android would become unstable and hard-to-recover when a website opened too…Priority LOW 21
- Release ·
Mozilla Firefox ESR, Thunderbird 78.11
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2021-10584 Out-of-bounds write in Mozilla ThunderbirdPriority MEDIUM 41
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
Not affected: 2 products
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-29964
- 2026-10-03 Alias added: GHSA-6mgf-v5gc-vgc7
References
More Mozilla Firefox vulnerabilities
- TI-2024-08981 Use after free in Mozilla Firefox KEVCVSS 3.1CRITICAL 9.8
- TI-2022-09832 Use after free in Mozilla Firefox KEVCVSS 3.1CRITICAL 9.6
- TI-2019-08769 Improper input validation in Mozilla Firefox ESR KEVCVSS 3.1CRITICAL 10.0
- TI-2010-03577 Mozilla Firefox 3.5.x through 3.5.14 and 3.6.x through 3.6.11, Thunderbird 3.1.6 before… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-04799 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
- TI-2023-04477 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2021-29964 · CVE Program
- CVE-2021-29964 · NVD
- FIRST EPSS
- GHSA-6mgf-v5gc-vgc7 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-29964 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences