docsify 4.12.1 is affected by Cross Site Scripting (XSS) because the search component…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
docsify 4.12.1 is affected by Cross Site Scripting (XSS) because the search component does not appropriately encode Code Blocks and mishandles the " character.
Why it matters now
EPSS 0.00785 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed docsify (npm): 4.12.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | docsify (npm) | before 4.12.2 | 4.12.2 | Patch available | GHSA-5h7x-68wj-jhwc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- docsify (npm) Vendor— Affected before 4.12.2 Fixed in 4.12.2 Patch available GHSA-5h7x-68wj-jhwc
Remediation
- Fix · GHSA-5h7x-68wj-jhwc docsify (npm) Fixed in 4.12.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-30074
- 2026-10-03 Alias added: GHSA-5h7x-68wj-jhwc
References
More Docsifyjs Docsify vulnerabilities
- TI-2021-06040 Cross-site scripting (XSS) in docsify CVSS 3.1HIGH 8.6
- TI-2020-06200 Cross-site scripting in docsify CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-30074 · CVE Program
- CVE-2021-30074 · NVD
- FIRST EPSS
- GHSA-5h7x-68wj-jhwc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences