phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.
Priority LOW 35CWE-347Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Spoofing
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-347 and CWE-295.
Summary
phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.
Why it matters now
EPSS 0.01055 64th percentileScored 2026-11-07
Fix Fixed phpseclib/phpseclib (Packagist): 3.0.7, 2.0.31
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpseclib/phpseclib (Packagist) | 3.0.0 to before 3.0.7 | 3.0.7 | Patch available | GHSA-vf4w-fg7r-5v94 |
| — | phpseclib/phpseclib (Packagist) | before 2.0.31 | 2.0.31 | Patch available | GHSA-vf4w-fg7r-5v94 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpseclib/phpseclib (Packagist) Vendor— Affected 3.0.0 to before 3.0.7 Fixed in 3.0.7 Patch available GHSA-vf4w-fg7r-5v94
- phpseclib/phpseclib (Packagist) Vendor— Affected before 2.0.31 Fixed in 2.0.31 Patch available GHSA-vf4w-fg7r-5v94
Remediation
- Fix · GHSA-vf4w-fg7r-5v94 phpseclib/phpseclib (Packagist) Fixed in 3.0.7 Advisory →
- Fix · GHSA-vf4w-fg7r-5v94 phpseclib/phpseclib (Packagist) Fixed in 2.0.31 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-30130
- 2026-10-03 Alias added: GHSA-vf4w-fg7r-5v94
References
Advisory 5
- https://github.com/phpseclib/phpseclib/releases/tag/3.0.7
- https://github.com/phpseclib/phpseclib/releases/tag/2.0.31
- [debian-lts-announce] 20221117 [SECURITY] [DLA 3197-1] phpseclib security update
- [debian-lts-announce] 20221117 [SECURITY] [DLA 3198-1] php-phpseclib security update
- https://nvd.nist.gov/vuln/detail/CVE-2021-30130
Sources
- CVE-2021-30130 · CVE Program
- CVE-2021-30130 · NVD
- FIRST EPSS
- GHSA-vf4w-fg7r-5v94 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-30130 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences