A cross-site scripting (XSS) vulnerability in CloverDX Server 5.9.0, CloverDX 5.8.1…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A cross-site scripting (XSS) vulnerability in CloverDX Server 5.9.0, CloverDX 5.8.1, CloverDX 5.7.0, and earlier allows remote attackers to inject arbitrary web script or HTML via the sessionToken parameter of multiple methods in Simple HTTP API. This is resolved in 5.9.1 and 5.10.
Why it matters now
EPSS 0.00754 55th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-30133
- 2026-10-03 Alias added: GHSA-qg22-34xc-h6jh
References
More Cloverdx vulnerabilities
- TI-2021-10611 A Cross Site Request Forgery (CSRF) issue in Server Console in CloverDX through 5.9.0… CVSS 3.1HIGH 8.8
- TI-2023-14785 CloverDX before 5.17.3 writes passwords to the audit log in certain situations, if the… CVSS 3.1CRITICAL 9.1
- TI-2021-18978 CloverDX Server before 5.11.2 and and 5.12.x before 5.12.1 allows XXE during configuration import. CVSS 3.1HIGH 7.7
Sources
- CVE-2021-30133 · CVE Program
- CVE-2021-30133 · NVD
- FIRST EPSS
- GHSA-qg22-34xc-h6jh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences