php-mod/curl (a wrapper of the PHP cURL extension) before 2.3.2 allows XSS via the…
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
php-mod/curl (a wrapper of the PHP cURL extension) before 2.3.2 allows XSS via the post_file_path_upload.php key parameter and the POST data to post_multidimensional.php.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01324 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed php-mod/curl (Packagist): 2.3.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | php-mod/curl (Packagist) | before 2.3.2 | 2.3.2 | Patch available | GHSA-f8p3-q834-q9cj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- php-mod/curl (Packagist) Vendor— Affected before 2.3.2 Fixed in 2.3.2 Patch available GHSA-f8p3-q834-q9cj
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:php_curl_class_project:php_curl_class:*:*:*:*:*:*:*:* | before 2.3.2 | Vulnerable | Php Curl Class Project |
| cpe:2.3:a:ht_slider_range_for_amazon_affiliates_project:ht_slider_range_for_amazon_affiliates:*:*:*:*:*:wordpress:*:* | before 1.1.6 | Vulnerable | Ht Slider Range For Amazon Affiliates Project |
| cpe:2.3:a:qiwi:woo-qiwi-payment-gateway:*:*:*:*:*:wordpress:*:* | up to 0.0.9 | Vulnerable | Qiwi |
| cpe:2.3:a:teamleade:teamleader_crm_forms:*:*:*:*:*:wordpress:*:* | before 2.1.0 | Vulnerable | Teamleade |
| cpe:2.3:a:ptwooplugins:invoicing_with_invoicexpress_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 3.0.3 | Vulnerable | Ptwooplugins |
| cpe:2.3:a:shopello_api_project:shopello_api:*:*:*:*:*:wordpress:*:* | up to 2.9.0 | Vulnerable | Shopello Api Project |
- cpe:2.3:a:php_curl_class_project:php_curl_class:*:*:*:*:*:*:*:* Versions before 2.3.2 Vulnerable ·Php Curl Class Project
- cpe:2.3:a:ht_slider_range_for_amazon_affiliates_project:ht_slider_range_for_amazon_affiliates:*:*:*:*:*:wordpress:*:* Versions before 1.1.6 Vulnerable ·Ht Slider Range For Amazon Affiliates Project
- cpe:2.3:a:qiwi:woo-qiwi-payment-gateway:*:*:*:*:*:wordpress:*:* Versions up to 0.0.9 Vulnerable ·Qiwi
- cpe:2.3:a:teamleade:teamleader_crm_forms:*:*:*:*:*:wordpress:*:* Versions before 2.1.0 Vulnerable ·Teamleade
- cpe:2.3:a:ptwooplugins:invoicing_with_invoicexpress_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 3.0.3 Vulnerable ·Ptwooplugins
- cpe:2.3:a:shopello_api_project:shopello_api:*:*:*:*:*:wordpress:*:* Versions up to 2.9.0 Vulnerable ·Shopello Api Project
Remediation
- Fix · GHSA-f8p3-q834-q9cj php-mod/curl (Packagist) Fixed in 2.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-30134
- 2026-10-03 Alias added: GHSA-f8p3-q834-q9cj
References
Sources
- CVE-2021-30134 · CVE Program
- CVE-2021-30134 · NVD
- FIRST EPSS
- GHSA-f8p3-q834-q9cj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences