In the jsrsasign package through 10.1.13 for Node.js, some invalid RSA PKCS#1 v1.5…
Priority MEDIUM 41CWE-347Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-347.
Summary
In the jsrsasign package through 10.1.13 for Node.js, some invalid RSA PKCS#1 v1.5 signatures are mistakenly recognized to be valid. NOTE: there is no known practical attack.
Why it matters now
EPSS 0.0096 61st percentileScored 2026-11-07
Fix Fixed jsrsasign (npm): 10.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | jsrsasign (npm) | before 10.2.0 | 10.2.0 | Patch available | GHSA-27fj-mc8w-j9wg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- jsrsasign (npm) Vendor— Affected before 10.2.0 Fixed in 10.2.0 Patch available GHSA-27fj-mc8w-j9wg
Remediation
- Fix · GHSA-27fj-mc8w-j9wg jsrsasign (npm) Fixed in 10.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-30246
- 2026-10-03 Alias added: GHSA-27fj-mc8w-j9wg
References
Advisory 4
More Kjur Jsrsasign vulnerabilities
- TI-2026-04006 Incorrect numeric conversion in jsrsasign CVSS 4.0HIGH 8.7
- TI-2026-04002 Infinite loop in jsrsasign CVSS 4.0HIGH 8.7
- TI-2026-04004 Improper signature verification in jsrsasign CVSS 4.0CRITICAL 9.1
- TI-2026-04003 Versions of the package jsrsasign from 7.0.0 and before 11.1.1 are vulnerable to… CVSS 4.0CRITICAL 9.3
- TI-2020-11771 An issue was discovered in the jsrsasign package before 8.0.17 for Node.js. CVSS 3.1CRITICAL 9.8
- TI-2020-11770 An issue was discovered in the jsrsasign package before 8.0.18 for Node.js. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-30246 · CVE Program
- CVE-2021-30246 · NVD
- FIRST EPSS
- GHSA-27fj-mc8w-j9wg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences