Use after free in Google Chrome
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-416 and the CVSS impact.
Summary
Use after free in Blink XSLT in Google Chrome prior to 91.0.4472.164 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Chrome | before 91.0.4472.164 | 91.0.4472.164 | Patch available | CNA | |
| — | nokogiri (RubyGems) | before 1.13.2 | 1.13.2 | Patch available | GHSA-59gp-qqm7-cw4j |
- Chrome VendorGoogle Affected before 91.0.4472.164 Fixed in 91.0.4472.164 Patch available CNA
- nokogiri (RubyGems) Vendor— Affected before 1.13.2 Fixed in 1.13.2 Patch available GHSA-59gp-qqm7-cw4j
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* | before 91.0.4472.164 | Vulnerable | |
| cpe:2.3:a:xmlsoft:libxslt:*:*:*:*:*:*:*:* | before 1.1.35 | Vulnerable | xmlsoft |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:a:splunk:universal_forwarder:*:*:*:*:*:*:*:* | 8.2.0 to before 8.2.12; 9.0.0 to before 9.0.6 | Vulnerable | Splunk |
| cpe:2.3:a:splunk:universal_forwarder:9.1.0:*:*:*:*:*:*:* | 9.1.0 | Vulnerable | Splunk |
- cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* Versions before 91.0.4472.164 Vulnerable ·Google
- cpe:2.3:a:xmlsoft:libxslt:*:*:*:*:*:*:*:* Versions before 1.1.35 Vulnerable ·xmlsoft
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:a:splunk:universal_forwarder:*:*:*:*:*:*:*:* Versions 8.2.0 to before 8.2.12; 9.0.0 to before 9.0.6 Vulnerable ·Splunk
- cpe:2.3:a:splunk:universal_forwarder:9.1.0:*:*:*:*:*:*:* Versions 9.1.0 Vulnerable ·Splunk
Remediation
- Fix · CNA Chrome (Google) Fixed in 91.0.4472.164
- Fix · GHSA-59gp-qqm7-cw4j nokogiri (RubyGems) Fixed in 1.13.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Google Chrome 91.0.4472.164
7 records Highest priority Priority CRITICAL 1 CRITICAL, 6 MEDIUM
Other records, highest priority first
- TI-2021-10958 Type confusion in Google ChromePriority CRITICAL 97
- TI-2021-10956 Type confusion in Google ChromePriority MEDIUM 46
- TI-2021-10936 Use after free in Google ChromePriority MEDIUM 42
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-30560
- 2026-10-03 Alias added: GHSA-59gp-qqm7-cw4j
References
Patch 1
Advisory 5
More Google Chrome vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2021-30560 · CVE Program
- CVE-2021-30560 · NVD
- FIRST EPSS
- GHSA-59gp-qqm7-cw4j · GitHub Advisory Database · CC BY 4.0
- CVE-2021-30560 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences