The dio package 4.0.0 for Dart allows CRLF injection if the attacker controls the HTTP…
Priority LOW 35CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
The dio package 4.0.0 for Dart allows CRLF injection if the attacker controls the HTTP method string, a different vulnerability than CVE-2020-35669.
Why it matters now
EPSS 0.01167 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed dio (Pub): 5.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | dio (Pub) | before 5.0.0 | 5.0.0 | Patch available | GHSA-9324-jv53-9cc8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- dio (Pub) Vendor— Affected before 5.0.0 Fixed in 5.0.0 Patch available GHSA-9324-jv53-9cc8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:flutterchina:dio:*:*:*:*:*:dart:*:* | 4.0.0 to before 5.0.0 | Vulnerable | Flutterchina |
- cpe:2.3:a:flutterchina:dio:*:*:*:*:*:dart:*:* Versions 4.0.0 to before 5.0.0 Vulnerable ·Flutterchina
Remediation
- Fix · GHSA-9324-jv53-9cc8 dio (Pub) Fixed in 5.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-31402
- 2026-10-03 Alias added: GHSA-9324-jv53-9cc8
References
Sources
- CVE-2021-31402 · CVE Program
- CVE-2021-31402 · NVD
- FIRST EPSS
- GHSA-9324-jv53-9cc8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences