Incorrect default permissions in Octopus Tentacle
Priority LOW 33CWE-276Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
When Octopus Tentacle is installed on a Linux operating system, the systemd service file permissions are misconfigured. This could lead to a local unprivileged user modifying the contents of the systemd service file to gain privileged access.
Why it matters now
EPSS 0.00215 11th percentileScored 2026-11-07
Fix Fixed Octopus Tentacle (Octopus Deploy): 6.1.1116
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Tentacle | 3.15.4 and later; before 6.1.1116 | 6.1.1116 | Patch available | CNA |
- Octopus Tentacle VendorOctopus Deploy Affected 3.15.4 and later; before 6.1.1116 Fixed in 6.1.1116 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:tentacle:*:*:*:*:*:*:*:* | 3.15.4 to before 6.1.1116 | Vulnerable | Octopus Deploy |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
- cpe:2.3:a:octopus:tentacle:*:*:*:*:*:*:*:* Versions 3.15.4 to before 6.1.1116 Vulnerable ·Octopus Deploy
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
Remediation
- Fix · CNA Octopus Tentacle (Octopus Deploy) Fixed in 6.1.1116
Timeline
- 2026-10-02 Threatist record created from CVE-2021-31822
- 2026-10-03 Alias added: GHSA-gv66-6m64-mx48
References
More Octopus Deploy Tentacle vulnerabilities
- TI-2021-08281 Untrusted search path in Octopus Tentacle CVSS 3.1HIGH 7.8
- TI-2019-11610 In Octopus Tentacle versions 3.0.8 to 5.0.0, when a web request proxy is configured, an… CVSS 3.0MEDIUM 6.5
- TI-2021-11818 Cleartext storage of sensitive information in Octopus Tentacle CVSS 3.1MEDIUM 5.5
Sources
- CVE-2021-31822 · CVE Program
- CVE-2021-31822 · NVD
- FIRST EPSS
- GHSA-gv66-6m64-mx48 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences