inn: %post calls user owned file allowing local privilege escalation to root
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A Incorrect Default Permissions vulnerability in the packaging of inn of SUSE Linux Enterprise Server 11-SP3; openSUSE Backports SLE-15-SP2, openSUSE Leap 15.2 allows local attackers to escalate their privileges from the news user to root. This issue affects: SUSE Linux Enterprise Server 11-SP3 inn version inn-2.4.2-170.21.3.1 and prior versions. openSUSE Backports SLE-15-SP2 inn versions prior to 2.6.2. openSUSE Leap 15.2 inn versions prior to 2.6.2.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE Linux Enterprise Server 11-SP3 | inn – inn-2.4.2-170.21.3.1 | — | No fix listed | CNA |
| openSUSE | openSUSE Backports SLE-15-SP2 | inn to before 2.6.2 | 2.6.2 | Patch available | CNA |
| openSUSE | openSUSE Leap 15.2 | inn to before 2.6.2 | 2.6.2 | Patch available | CNA |
- SUSE Linux Enterprise Server 11-SP3 VendorSUSE Affected inn – inn-2.4.2-170.21.3.1 Fixed in — No fix listed CNA
- openSUSE Backports SLE-15-SP2 VendoropenSUSE Affected inn to before 2.6.2 Fixed in 2.6.2 Patch available CNA
- openSUSE Leap 15.2 VendoropenSUSE Affected inn to before 2.6.2 Fixed in 2.6.2 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opensuse:inn:*:*:*:*:*:*:*:* | up to 2.4.2-170.21.3.1 | Vulnerable | openSUSE |
| cpe:2.3:o:suse:linux_enterprise_server:11:sp3:*:*:*:-:*:* | 11 sp3 | Running on | SUSE |
| cpe:2.3:a:opensuse:inn:*:*:*:*:*:*:*:* | before 2.6.2 | Vulnerable | openSUSE |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp2:*:*:*:*:*:* | 15.0 sp2 | Running on | openSUSE |
| cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* | 15.2 | Running on | openSUSE |
- cpe:2.3:a:opensuse:inn:*:*:*:*:*:*:*:* Versions up to 2.4.2-170.21.3.1 Vulnerable ·openSUSE
- cpe:2.3:o:suse:linux_enterprise_server:11:sp3:*:*:*:-:*:* Versions 11 sp3 Running on ·SUSE
- cpe:2.3:a:opensuse:inn:*:*:*:*:*:*:*:* Versions before 2.6.2 Vulnerable ·openSUSE
- cpe:2.3:a:opensuse:backports_sle:15.0:sp2:*:*:*:*:*:* Versions 15.0 sp2 Running on ·openSUSE
- cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Running on ·openSUSE
Remediation
- Fix · CNA openSUSE Backports SLE-15-SP2 (openSUSE) Fixed in 2.6.2
- Fix · CNA openSUSE Leap 15.2 (openSUSE) Fixed in 2.6.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-31998
- 2026-10-03 Alias added: GHSA-rqpg-j7j6-g58g
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-31998 · CVE Program
- CVE-2021-31998 · NVD
- FIRST EPSS
- GHSA-rqpg-j7j6-g58g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences