Read the docs
TI-2021-12057 Aliases CVE-2021-32106GHSA-jf9v-q8vh-3fmc

In ICEcoder 8.0 allows, a reflected XSS vulnerability was identified in the…

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

In ICEcoder 8.0 allows, a reflected XSS vulnerability was identified in the multipe-results.php page due to insufficient sanitization of the _GET['replace'] variable. As a result, arbitrary Javascript code can get executed.

Why it matters now

EPSS 0.00859 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed icecoder/icecoder (Packagist): 8.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—icecoder/icecoder (Packagist)before 8.18.1Patch availableGHSA-jf9v-q8vh-3fmc
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • icecoder/icecoder (Packagist) Vendor— Affected before 8.1 Fixed in 8.1 Patch available GHSA-jf9v-q8vh-3fmc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:icecoder:icecoder:8.0:-:*:*:*:*:*:*8.0VulnerableICEcoder
  • cpe:2.3:a:icecoder:icecoder:8.0:-:*:*:*:*:*:* Versions 8.0 Vulnerable ·ICEcoder

Remediation

  • Fix · GHSA-jf9v-q8vh-3fmc icecoder/icecoder (Packagist) Fixed in 8.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-32106
  2. 2026-10-03 Alias added: GHSA-jf9v-q8vh-3fmc

References

  • TI-2022-15006 ICEcoder v8.1 allows attackers to execute a directory traversal. CVSS 3.1HIGH 7.5
  • TI-2024-27614 ICEcoder 8.1 contains a Path Traversal vulnerability via lib/backup-versions-preview-loader.php. CVSS 3.1MEDIUM 6.3
  • TI-2024-27616 ICEcoder 8.1 is vulnerable to Cross Site Scripting (XSS) via lib/terminal-xhr.php CVSS 3.1MEDIUM 6.1
  • TI-2024-27615 ICEcoder 8.1 is vulnerable to Cross Site Scripting (XSS) via lib/settings-screen.php CVSS 3.1MEDIUM 6.1
  • TI-2021-02793 Cross-site Scripting (XSS) - Reflected in icecoder/icecoder CVSS 3.1MEDIUM 4.8

Sources