OctoPrint before 1.6.0 allows XSS because API error messages include the values of input parameters.
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
OctoPrint before 1.6.0 allows XSS because API error messages include the values of input parameters.
Why it matters now
EPSS 0.01148 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed OctoPrint (PyPI): 1.6.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | OctoPrint (PyPI) | before 1.6.0 | 1.6.0 | Patch available | GHSA-vcx4-fpmp-mvv6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- OctoPrint (PyPI) Vendor— Affected before 1.6.0 Fixed in 1.6.0 Patch available GHSA-vcx4-fpmp-mvv6
Remediation
- Fix · GHSA-vcx4-fpmp-mvv6 OctoPrint (PyPI) Fixed in 1.6.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32561
- 2026-10-03 Alias added: GHSA-vcx4-fpmp-mvv6
References
Advisory 3
More Octoprint vulnerabilities
- TI-2022-02830 Improper Privilege Management in octoprint/octoprint CVSS 3.1HIGH 8.8
- TI-2022-03320 Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) in octoprint/octoprint CVSS 3.1MEDIUM 6.0
- TI-2022-02664 Unrestricted Upload of File with Dangerous Type in octoprint/octoprint CVSS 3.1MEDIUM 5.4
- TI-2025-35988 OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload CVSS 4.0HIGH 7.5
- TI-2024-18796 OctoPrint XSS via the "Snapshot Test" feature in Classic Webcam plugin settings CVSS 3.1MEDIUM 4.8
- TI-2022-02678 Insufficient Session Expiration in octoprint/octoprint CVSS 3.1MEDIUM 4.4
Sources
- CVE-2021-32561 · CVE Program
- CVE-2021-32561 · NVD
- FIRST EPSS
- GHSA-vcx4-fpmp-mvv6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences