Possible bypass of token claim validation when OAuth2 Introspection caching is enabled
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
ORY Oathkeeper is an Identity & Access Proxy (IAP) and Access Control Decision API that authorizes HTTP requests based on sets of Access Rules. When you make a request to an endpoint that requires the scope `foo` using an access token granted with that `foo` scope, introspection will be valid and that token will be cached. The problem comes when a second requests to an endpoint that requires the scope `bar` is made before the cache has expired. Whether the token is granted or not to the `bar` scope, introspection will be valid. A patch will be released with `v0.38.12-beta.1`. Per default, caching is disabled for the `oauth2_introspection` authenticator. When caching is disabled, this vulnerability does not exist. The cache is checked in [`func (a *AuthenticatorOAuth2Introspection) Authenticate(...)`](https://github.com/ory/oathkeeper/blob/6a31df1c3779425e05db1c2a381166b087cb29a4/pipeline/authn/authenticator_oauth2_introspection.go#L152). From [`tokenFromCache()`](https://github.com/ory/oathkeeper/blob/6a31df1c3779425e05db1c2a381166b087cb29a4/pipeline/authn/authenticator_oauth2_introspection.go#L97) it seems that it only validates the token expiration date, but ignores whether the token has or not the proper scopes. The vulnerability was introduced in PR #424. During review, we failed to require appropriate test coverage by the submitter which is the primary reason that the vulnerability passed the review process.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ory | oathkeeper | v0.38.0-beta.2 to before v0.38.12-beta.1 | v0.38.12-beta.1 | Patch available | CNA |
| — | github.com/ory/oathkeeper (Go) | 0.38.0-beta.2 to before 0.38.12-beta.1 | 0.38.12-beta.1 | Patch available | GHSA-vfvf-6gx5-mqv6 |
- oathkeeper Vendorory Affected v0.38.0-beta.2 to before v0.38.12-beta.1 Fixed in v0.38.12-beta.1 Patch available CNA
- github.com/ory/oathkeeper (Go) Vendor— Affected 0.38.0-beta.2 to before 0.38.12-beta.1 Fixed in 0.38.12-beta.1 Patch available GHSA-vfvf-6gx5-mqv6
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ory:oathkeeper:0.38.0:beta2:*:*:*:*:*:* | 0.38.0 beta2 | Vulnerable | ory |
| cpe:2.3:a:ory:oathkeeper:0.38.1:beta2:*:*:*:*:*:* | 0.38.1 beta2 | Vulnerable | ory |
| cpe:2.3:a:ory:oathkeeper:0.38.2:beta1:*:*:*:*:*:* | 0.38.2 beta1 | Vulnerable | ory |
| cpe:2.3:a:ory:oathkeeper:0.38.3:beta1:*:*:*:*:*:* | 0.38.3 beta1 | Vulnerable | ory |
| cpe:2.3:a:ory:oathkeeper:0.38.4:beta1:*:*:*:*:*:* | 0.38.4 beta1 | Vulnerable | ory |
| cpe:2.3:a:ory:oathkeeper:0.38.5:beta1:*:*:*:*:*:* | 0.38.5 beta1 | Vulnerable | ory |
| cpe:2.3:a:ory:oathkeeper:0.38.6:beta1:*:*:*:*:*:* | 0.38.6 beta1 | Vulnerable | ory |
| cpe:2.3:a:ory:oathkeeper:0.38.7:beta1:*:*:*:*:*:* | 0.38.7 beta1 | Vulnerable | ory |
| cpe:2.3:a:ory:oathkeeper:0.38.8:beta1:*:*:*:*:*:* | 0.38.8 beta1 | Vulnerable | ory |
| cpe:2.3:a:ory:oathkeeper:0.38.9:beta1:*:*:*:*:*:* | 0.38.9 beta1 | Vulnerable | ory |
- cpe:2.3:a:ory:oathkeeper:0.38.0:beta2:*:*:*:*:*:* Versions 0.38.0 beta2 Vulnerable ·ory
- cpe:2.3:a:ory:oathkeeper:0.38.1:beta2:*:*:*:*:*:* Versions 0.38.1 beta2 Vulnerable ·ory
- cpe:2.3:a:ory:oathkeeper:0.38.2:beta1:*:*:*:*:*:* Versions 0.38.2 beta1 Vulnerable ·ory
- cpe:2.3:a:ory:oathkeeper:0.38.3:beta1:*:*:*:*:*:* Versions 0.38.3 beta1 Vulnerable ·ory
- cpe:2.3:a:ory:oathkeeper:0.38.4:beta1:*:*:*:*:*:* Versions 0.38.4 beta1 Vulnerable ·ory
- cpe:2.3:a:ory:oathkeeper:0.38.5:beta1:*:*:*:*:*:* Versions 0.38.5 beta1 Vulnerable ·ory
- cpe:2.3:a:ory:oathkeeper:0.38.6:beta1:*:*:*:*:*:* Versions 0.38.6 beta1 Vulnerable ·ory
- cpe:2.3:a:ory:oathkeeper:0.38.7:beta1:*:*:*:*:*:* Versions 0.38.7 beta1 Vulnerable ·ory
- cpe:2.3:a:ory:oathkeeper:0.38.8:beta1:*:*:*:*:*:* Versions 0.38.8 beta1 Vulnerable ·ory
- cpe:2.3:a:ory:oathkeeper:0.38.9:beta1:*:*:*:*:*:* Versions 0.38.9 beta1 Vulnerable ·ory
Remediation
- Fix · CNA oathkeeper (ory) Fixed in v0.38.12-beta.1
- Fix · GHSA-vfvf-6gx5-mqv6 github.com/ory/oathkeeper (Go) Fixed in 0.38.12-beta.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32701
- 2026-10-03 Alias added: GHSA-vfvf-6gx5-mqv6
References
More ory Oathkeeper vulnerabilities
- TI-2026-25890 Ory Oathkeeper has a path traversal authorization bypass CVSS 3.1CRITICAL 10.0
- TI-2026-25892 Ory Oathkeeper has an authentication bypass by cache key confusion CVSS 3.1HIGH 8.1
- TI-2026-25891 Ory Oathkeeper has an authentication bypass by usage of untrusted header CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-32701 · CVE Program
- CVE-2021-32701 · NVD
- FIRST EPSS
- GHSA-vfvf-6gx5-mqv6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences