Remote Code Execution via Script (Python) objects under Python 3
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-915.
Summary
Zope is an open-source web application server. Zope versions prior to versions 4.6.3 and 5.3 have a remote code execution security issue. In order to be affected, one must use Python 3 for one's Zope deployment, run Zope 4 below version 4.6.3 or Zope 5 below version 5.3, and have the optional `Products.PythonScripts` add-on package installed. By default, one must have the admin-level Zope "Manager" role to add or edit Script (Python) objects through the web. Only sites that allow untrusted users to add/edit these scripts through the web are at risk. Zope releases 4.6.3 and 5.3 are not vulnerable. As a workaround, a site administrator can restrict adding/editing Script (Python) objects through the web using the standard Zope user/role permission mechanisms. Untrusted users should not be assigned the Zope Manager role and adding/editing these scripts through the web should be restricted to trusted users only. This is the default configuration in Zope.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| zopefoundation | Zope | 4.0 to before 4.6.3; 5.0 to before 5.3 | 4.6.3, 5.3 | Patch available | CNA |
| — | Zope (PyPI) | 4.0 to before 4.6.3 | 4.6.3 | Patch available | GHSA-g4gq-j4p2-j8fr |
| — | Zope (PyPI) | 5.0 to before 5.3 | 5.3 | Patch available | GHSA-g4gq-j4p2-j8fr |
- Zope Vendorzopefoundation Affected 4.0 to before 4.6.3; 5.0 to before 5.3 Fixed in 4.6.3, 5.3 Patch available CNA
- Zope (PyPI) Vendor— Affected 4.0 to before 4.6.3 Fixed in 4.6.3 Patch available GHSA-g4gq-j4p2-j8fr
- Zope (PyPI) Vendor— Affected 5.0 to before 5.3 Fixed in 5.3 Patch available GHSA-g4gq-j4p2-j8fr
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zope:accesscontrol:*:*:*:*:*:*:*:* | 4.0 to before 4.3; 5.0 to before 5.2 | Vulnerable | zopefoundation |
| cpe:2.3:a:zope:zope:*:*:*:*:*:*:*:* | 4.0 to before 4.6.3; 5.0 to before 5.3 | Vulnerable | zopefoundation |
- cpe:2.3:a:zope:accesscontrol:*:*:*:*:*:*:*:* Versions 4.0 to before 4.3; 5.0 to before 5.2 Vulnerable ·zopefoundation
- cpe:2.3:a:zope:zope:*:*:*:*:*:*:*:* Versions 4.0 to before 4.6.3; 5.0 to before 5.3 Vulnerable ·zopefoundation
Remediation
- Fix · CNA Zope (zopefoundation) Fixed in 4.6.3, 5.3
- Fix · GHSA-g4gq-j4p2-j8fr Zope (PyPI) Fixed in 4.6.3 Advisory →
- Fix · GHSA-g4gq-j4p2-j8fr Zope (PyPI) Fixed in 5.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32811
- 2026-10-03 Alias added: GHSA-g4gq-j4p2-j8fr
References
Advisory 3
More zopefoundation Accesscontrol vulnerabilities
- TI-2021-12472 Remote Code Execution via unsafe classes in otherwise permitted modules CVSS 3.1HIGH 7.2
- TI-2023-21676 Information disclosure through Python's "format" functionality in Zope AccessControl CVSS 3.1HIGH 7.7
Sources
- CVE-2021-32811 · CVE Program
- CVE-2021-32811 · NVD
- FIRST EPSS
- GHSA-g4gq-j4p2-j8fr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences