jQuery MiniColors vulnerable to Cross-site Scripting
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Mind-elixir is a free, open source mind map core. Prior to version 0.18.1, mind-elixir is prone to cross-site scripting when handling untrusted menus. This issue is patched in version 0.18.1
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00684 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mind-elixir (npm): 0.18.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| npm | mind-elixir | 0.18.1 to before 0.18.1 | 0.18.1 | Patch available | CNA |
| — | mind-elixir (npm) | before 0.18.1 | 0.18.1 | Patch available | GHSA-m22q-97p5-79v2 |
- mind-elixir Vendornpm Affected 0.18.1 to before 0.18.1 Fixed in 0.18.1 Patch available CNA
- mind-elixir (npm) Vendor— Affected before 0.18.1 Fixed in 0.18.1 Patch available GHSA-m22q-97p5-79v2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mind-elixir_project:mind-elixir:*:*:*:*:*:node.js:*:* | before 0.18.1 | Vulnerable | Mind-elixir Project |
- cpe:2.3:a:mind-elixir_project:mind-elixir:*:*:*:*:*:node.js:*:* Versions before 0.18.1 Vulnerable ·Mind-elixir Project
Remediation
- Fix · CNA mind-elixir (npm) Fixed in 0.18.1
- Fix · GHSA-m22q-97p5-79v2 mind-elixir (npm) Fixed in 0.18.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32851
- 2026-10-03 Alias added: GHSA-m22q-97p5-79v2
References
Patch 1
Advisory 3
Sources
- CVE-2021-32851 · CVE Program
- CVE-2021-32851 · NVD
- FIRST EPSS
- GHSA-m22q-97p5-79v2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences