iziModal vulnerable to Cross-site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
iziModal is a modal plugin with jQuery. Versions prior to 1.6.1 are vulnerable to cross-site scripting (XSS) when handling untrusted modal titles. An attacker who is able to influence the field `title` when creating a `iziModal` instance is able to supply arbitrary `html` or `javascript` code that will be rendered in the context of a user, potentially leading to `XSS`. Version 1.6.1 contains a patch for this issue
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| npm | iziModal | 1.6.1 to before 1.6.1 | 1.6.1 | Patch available | CNA |
| — | izimodal (npm) | before 1.6.1 | 1.6.1 | Patch available | GHSA-h685-83w4-3ph3 |
- iziModal Vendornpm Affected 1.6.1 to before 1.6.1 Fixed in 1.6.1 Patch available CNA
- izimodal (npm) Vendor— Affected before 1.6.1 Fixed in 1.6.1 Patch available GHSA-h685-83w4-3ph3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:izimodal_project:izimodal:*:*:*:*:*:*:*:* | up to 1.6.1 | Vulnerable | Izimodal Project |
- cpe:2.3:a:izimodal_project:izimodal:*:*:*:*:*:*:*:* Versions up to 1.6.1 Vulnerable ·Izimodal Project
Remediation
- Fix · CNA iziModal (npm) Fixed in 1.6.1
- Fix · GHSA-h685-83w4-3ph3 izimodal (npm) Fixed in 1.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-32860
- 2026-10-03 Alias added: GHSA-h685-83w4-3ph3
References
Advisory 3
Sources
- CVE-2021-32860 · CVE Program
- CVE-2021-32860 · NVD
- FIRST EPSS
- GHSA-h685-83w4-3ph3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences