managers/views/iframe.js in FuturePress EPub.js before 0.3.89 allows XSS.
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
managers/views/iframe.js in FuturePress EPub.js before 0.3.89 allows XSS.
Why it matters now
EPSS 0.00937 61st percentileScored 2026-11-07
Fix Fixed epubjs (npm): 0.3.89
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | epubjs (npm) | before 0.3.89 | 0.3.89 | Patch available | GHSA-c6rp-xvqv-mwmf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- epubjs (npm) Vendor— Affected before 0.3.89 Fixed in 0.3.89 Patch available GHSA-c6rp-xvqv-mwmf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:futurepress:epub.js:*:*:*:*:*:node.js:*:* | before 0.3.89 | Vulnerable | Futurepress |
- cpe:2.3:a:futurepress:epub.js:*:*:*:*:*:node.js:*:* Versions before 0.3.89 Vulnerable ·Futurepress
Remediation
- Fix · GHSA-c6rp-xvqv-mwmf epubjs (npm) Fixed in 0.3.89 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-33040
- 2026-10-03 Alias added: GHSA-c6rp-xvqv-mwmf
References
Advisory 3
Sources
- CVE-2021-33040 · CVE Program
- CVE-2021-33040 · NVD
- FIRST EPSS
- GHSA-c6rp-xvqv-mwmf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences