Zope Products.CMFCore before 2.5.1 and Products.PluggableAuthService before 2.6.2, as…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Zope Products.CMFCore before 2.5.1 and Products.PluggableAuthService before 2.6.2, as used in Plone through 5.2.4 and other products, allow Reflected XSS.
Why it matters now
EPSS 0.0075 55th percentileScored 2026-11-07
Fix Fixed Products.CMFCore (PyPI): 2.5.1Products.PluggableAuthService (PyPI): 2.6.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Products.CMFCore (PyPI) | before 2.5.1 | 2.5.1 | Patch available | GHSA-35rg-466w-77h3 |
| — | Products.PluggableAuthService (PyPI) | before 2.6.2 | 2.6.2 | Patch available | GHSA-35rg-466w-77h3 |
| — | Plone (PyPI) | up to 5.2.4 | — | No fix listed | GHSA-35rg-466w-77h3 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Products.CMFCore (PyPI) Vendor— Affected before 2.5.1 Fixed in 2.5.1 Patch available GHSA-35rg-466w-77h3
- Products.PluggableAuthService (PyPI) Vendor— Affected before 2.6.2 Fixed in 2.6.2 Patch available GHSA-35rg-466w-77h3
- Plone (PyPI) Vendor— Affected up to 5.2.4 Fixed in — No fix listed GHSA-35rg-466w-77h3
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:plone:plone:*:*:*:*:*:*:*:* | up to 4.3.20; 5.0 – 5.2.4 | Vulnerable | plone |
| cpe:2.3:a:zope:zope:*:*:*:*:*:*:*:* | before 2.5.1 | Vulnerable | zopefoundation |
- cpe:2.3:a:plone:plone:*:*:*:*:*:*:*:* Versions up to 4.3.20; 5.0 – 5.2.4 Vulnerable ·plone
- cpe:2.3:a:zope:zope:*:*:*:*:*:*:*:* Versions before 2.5.1 Vulnerable ·zopefoundation
Remediation
- Fix · GHSA-35rg-466w-77h3 Products.CMFCore (PyPI) Fixed in 2.5.1 Advisory →
- Fix · GHSA-35rg-466w-77h3 Products.PluggableAuthService (PyPI) Fixed in 2.6.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-33507
- 2026-10-03 Alias added: GHSA-35rg-466w-77h3
References
Advisory 4
Sources
- CVE-2021-33507 · CVE Program
- CVE-2021-33507 · NVD
- FIRST EPSS
- GHSA-35rg-466w-77h3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences