An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows…
Priority HIGH 80CWE-88Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-88.
Summary
An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verify_url option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.
Why it matters now
EPSS 0.72143 99th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed dragonfly (RubyGems): 1.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | dragonfly (RubyGems) | before 1.4.0 | 1.4.0 | Patch available | GHSA-j858-xp5v-f8xx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- dragonfly (RubyGems) Vendor— Affected before 1.4.0 Fixed in 1.4.0 Patch available GHSA-j858-xp5v-f8xx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dragonfly_project:dragonfly:*:*:*:*:*:ruby:*:* | before 1.4.0 | Vulnerable | Dragonfly Project |
- cpe:2.3:a:dragonfly_project:dragonfly:*:*:*:*:*:ruby:*:* Versions before 1.4.0 Vulnerable ·Dragonfly Project
Remediation
- Fix · GHSA-j858-xp5v-f8xx dragonfly (RubyGems) Fixed in 1.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-33564
- 2026-10-03 Alias added: GHSA-j858-xp5v-f8xx
References
Exploit 3
Patch 2
Advisory 3
More Dragonfly Project Dragonfly vulnerabilities
- TI-2021-12880 An argument injection vulnerability in Dragonfly Ruby Gem v1.3.0 allows attackers to read… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2021-33564 · CVE Program
- CVE-2021-33564 · NVD
- FIRST EPSS
- GHSA-j858-xp5v-f8xx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences