The css-what package 4.0.0 through 5.0.0 for Node.js does not ensure that attribute…
Priority LOW 37CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 5 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
The css-what package 4.0.0 through 5.0.0 for Node.js does not ensure that attribute parsing has Linear Time Complexity relative to the size of the input.
Why it matters now
EPSS 0.02036 81st percentileScored 2026-11-07
Fix Partial css-what (npm): 5.0.1Red Hat: 5 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | css-what (npm) | 4.0.0 to before 5.0.1 | 5.0.1 | Patch available | GHSA-q8pj-2vqx-8ggc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- css-what (npm) Vendor— Affected 4.0.0 to before 5.0.1 Fixed in 5.0.1 Patch available GHSA-q8pj-2vqx-8ggc
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:css-what_project:css-what:4.0.0:*:*:*:*:node.js:*:* | 4.0.0 | Vulnerable | Css-what Project |
| cpe:2.3:a:css-what_project:css-what:5.0.0:*:*:*:*:node.js:*:* | 5.0.0 | Vulnerable | Css-what Project |
| cpe:2.3:a:netapp:e-series_performance_analyzer:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
- cpe:2.3:a:css-what_project:css-what:4.0.0:*:*:*:*:node.js:*:* Versions 4.0.0 Vulnerable ·Css-what Project
- cpe:2.3:a:css-what_project:css-what:5.0.0:*:*:*:*:node.js:*:* Versions 5.0.0 Vulnerable ·Css-what Project
- cpe:2.3:a:netapp:e-series_performance_analyzer:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
Remediation
- Fix · GHSA-q8pj-2vqx-8ggc css-what (npm) Fixed in 5.0.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Service Mesh 2.0 | Affected | No fix yet |
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet |
| Red Hat Advanced Cluster Management for Kubernetes 2 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
| Red Hat Virtualization 4 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2021-33587
- 2026-10-03 Alias added: GHSA-q8pj-2vqx-8ggc
References
Advisory 2
Sources
- CVE-2021-33587 · CVE Program
- CVE-2021-33587 · NVD
- FIRST EPSS
- GHSA-q8pj-2vqx-8ggc · GitHub Advisory Database · CC BY 4.0
- CVE-2021-33587 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences