Cross-site scripting in SAP NetWeaver Application Server ABAP
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
SAP NetWeaver Application Server ABAP (Applications based on SAP GUI for HTML), versions - KRNL64NUC - 7.49, KRNL64UC - 7.49,7.53, KERNEL - 7.49,7.53,7.77,7.81,7.84, does not sufficiently encode user-controlled inputs, resulting in Cross-Site Scripting (XSS) vulnerability.
Why it matters now
EPSS 0.00473 41st percentileScored 2026-11-07
Fix Fixed SAP NetWeaver Application Server ABAP (Applications based on SAP GUI for HTML) (SAP SE): 7.53, 7.77, 7.81 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver Application Server ABAP (Applications based on SAP GUI for HTML) | < KRNL64NUC - 7.49; < KRNL64UC - 7.49; before 7.53; < KERNEL - 7.49; before 7.77; before 7.81; before 7.84 | 7.53, 7.77, 7.81, 7.84 | Patch available | CNA |
- SAP NetWeaver Application Server ABAP (Applications based on SAP GUI for HTML) VendorSAP Affected < KRNL64NUC - 7.49; < KRNL64UC - 7.49; before 7.53; < KERNEL - 7.49; before 7.77; before 7.81; before 7.84 Fixed in 7.53, 7.77, 7.81, 7.84 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_application_server_abap:kernel_7.49:*:*:*:*:*:*:* | kernel_7.49 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_abap:kernel_7.53:*:*:*:*:*:*:* | kernel_7.53 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_abap:kernel_7.77:*:*:*:*:*:*:* | kernel_7.77 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_abap:kernel_7.81:*:*:*:*:*:*:* | kernel_7.81 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_abap:kernel_7.84:*:*:*:*:*:*:* | kernel_7.84 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_abap:krnl64nuc_7.49:*:*:*:*:*:*:* | krnl64nuc_7.49 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_abap:krnl64uc_7.49:*:*:*:*:*:*:* | krnl64uc_7.49 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_abap:krnl64uc_7.53:*:*:*:*:*:*:* | krnl64uc_7.53 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_application_server_abap:kernel_7.49:*:*:*:*:*:*:* Versions kernel_7.49 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_abap:kernel_7.53:*:*:*:*:*:*:* Versions kernel_7.53 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_abap:kernel_7.77:*:*:*:*:*:*:* Versions kernel_7.77 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_abap:kernel_7.81:*:*:*:*:*:*:* Versions kernel_7.81 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_abap:kernel_7.84:*:*:*:*:*:*:* Versions kernel_7.84 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_abap:krnl64nuc_7.49:*:*:*:*:*:*:* Versions krnl64nuc_7.49 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_abap:krnl64uc_7.49:*:*:*:*:*:*:* Versions krnl64uc_7.49 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_abap:krnl64uc_7.53:*:*:*:*:*:*:* Versions krnl64uc_7.53 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver Application Server ABAP (Applications based on SAP GUI for HTML) (SAP SE) Fixed in 7.53, 7.77, 7.81, 7.84
Timeline
- 2026-10-02 Threatist record created from CVE-2021-33665
- 2026-10-03 Alias added: GHSA-v63x-mvcc-j8h6
References
More SAP Netweaver Application Server Abap vulnerabilities
- TI-2022-06811 SAP NetWeaver Application Server ABAP, SAP NetWeaver Application Server Java, ABAP… KEVCVSS 3.1CRITICAL 10.0
- TI-2023-21149 Missing Authorization check in SAP CommonCryptoLib CVSS 3.1CRITICAL 9.8
- TI-2023-12229 Directory Traversal vulnerability in SAP NetWeaver AS for ABAP and ABAP Platform CVSS 3.1CRITICAL 9.6
- TI-2023-12228 Directory Traversal vulnerability in SAP NetWeaver AS for ABAP and ABAP Platform CVSS 3.1CRITICAL 9.6
- TI-2021-19921 Code injection in SAP ABAP Server & ABAP Platform CVSS 3.1CRITICAL 9.8
- TI-2021-09062 Improper authentication in SAP NetWeaver AS ABAP and ABAP Platform CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-33665 · CVE Program
- CVE-2021-33665 · NVD
- FIRST EPSS
- GHSA-v63x-mvcc-j8h6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences