Cross-site scripting in SAP NetWeaver Enterprise Portal
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Under certain conditions, NetWeaver Enterprise Portal, versions - 7.30, 7.31, 7.40, 7.50, does not sufficiently encode URL parameters. An attacker can craft a malicious link and send it to a victim. A successful attack results in Reflected Cross-Site Scripting (XSS) vulnerability.
Why it matters now
EPSS 0.01482 74th percentileScored 2026-11-07
Fix Fixed SAP NetWeaver Enterprise Portal (Application Extensions) (SAP SE): 7.30, 7.31, 7.40 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver Enterprise Portal (Application Extensions) | before 7.30; before 7.31; before 7.40; before 7.50 | 7.30, 7.31, 7.40, 7.50 | Patch available | CNA |
- SAP NetWeaver Enterprise Portal (Application Extensions) VendorSAP Affected before 7.30; before 7.31; before 7.40; before 7.50 Fixed in 7.30, 7.31, 7.40, 7.50 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_enterprise_portal:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_enterprise_portal:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_enterprise_portal:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_enterprise_portal:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_enterprise_portal:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_enterprise_portal:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_enterprise_portal:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_enterprise_portal:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver Enterprise Portal (Application Extensions) (SAP SE) Fixed in 7.30, 7.31, 7.40, 7.50
Timeline
- 2026-10-02 Threatist record created from CVE-2021-33703
- 2026-10-03 Alias added: GHSA-mc4p-q6wc-4cwx
References
Advisory 4
- https://wiki.scn.sap.com/wiki/pages/viewpage.action?pageId=582222806
- https://launchpad.support.sap.com/#/notes/3072920
- 20220126 Onapsis Security Advisory 2021-0022: SAP Enterprise Portal - XSS RunContentCreation
- http://packetstormsecurity.com/files/165740/SAP-Enterprise-Portal-RunContentCreation-Cross-Site-Scripting.html
More SAP Netweaver Enterprise Portal vulnerabilities
- TI-2023-13271 Missing Authentication check in SAP NetWeaver Enterprise Portal CVSS 3.1MEDIUM 6.5
- TI-2023-11608 XML External Entity (XXE) vulnerability in SAP NetWeaver (SAP Enterprise Portal) CVSS 3.1MEDIUM 6.8
- TI-2021-13076 Cross-site scripting in SAP NetWeaver Enterprise Portal CVSS 3.1MEDIUM 6.1
- TI-2018-01817 Cross-site scripting in SAP NetWeaver Enterprise Portal CVSS 3.0MEDIUM 6.1
- TI-2022-13954 Cross-site scripting in SAP NetWeaver Enterprise Portal CVSS 3.1MEDIUM 6.1
- TI-2022-09569 Cross-site scripting in SAP NetWeaver Enterprise Portal CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-33703 · CVE Program
- CVE-2021-33703 · NVD
- FIRST EPSS
- GHSA-mc4p-q6wc-4cwx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences