Server-side request forgery in SAP NetWeaver Enterprise Portal
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The SAP NetWeaver Portal, versions - 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50, component Iviews Editor contains a Server-Side Request Forgery (SSRF) vulnerability which allows an unauthenticated attacker to craft a malicious URL which when clicked by a user can make any type of request (e.g. POST, GET) to any internal or external server. This can result in the accessing or modification of data accessible from the Portal but will not affect its availability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver Enterprise Portal | before 7.10; before 7.11; before 7.20; before 7.30; before 7.31; before 7.40; before 7.50 | 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50 | Patch available | CNA |
- SAP NetWeaver Enterprise Portal VendorSAP Affected before 7.10; before 7.11; before 7.20; before 7.30; before 7.31; before 7.40; before 7.50 Fixed in 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_portal:7.10:*:*:*:*:*:*:* | 7.10 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_portal:7.11:*:*:*:*:*:*:* | 7.11 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_portal:7.20:*:*:*:*:*:*:* | 7.20 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_portal:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_portal:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_portal:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_portal:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_portal:7.10:*:*:*:*:*:*:* Versions 7.10 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_portal:7.11:*:*:*:*:*:*:* Versions 7.11 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_portal:7.20:*:*:*:*:*:*:* Versions 7.20 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_portal:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_portal:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_portal:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_portal:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver Enterprise Portal (SAP SE) Fixed in 7.10, 7.11, 7.20, 7.30, 7.31, 7.40, 7.50
Timeline
- 2026-10-02 Threatist record created from CVE-2021-33705
- 2026-10-03 Alias added: GHSA-rwjf-4f53-289h
References
Advisory 2
More SAP Netweaver Portal vulnerabilities
- TI-2017-08476 Cross-site scripting (XSS) vulnerability in the DataArchivingService servlet in SAP… CVSS 3.0MEDIUM 6.1
- TI-2018-01753 Cross-site scripting in SAP NetWeaver Portal WebDynpro RunTime CVSS 3.0MEDIUM 6.1
Sources
- CVE-2021-33705 · CVE Program
- CVE-2021-33705 · NVD
- FIRST EPSS
- GHSA-rwjf-4f53-289h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences