Read the docs
TI-2021-13086 Aliases CVE-2021-33712GHSA-5xc3-hrwr-2p8h

Insufficient verification of data authenticity in Siemens Mendix SAML Module

Priority LOW 39CWE-345Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-345.

Summary

A vulnerability has been identified in Mendix SAML Module (All versions < V2.1.2). The configuration of the SAML module does not properly check various restrictions and validations imposed by an identity provider. This could allow a remote authenticated attacker to escalate privileges.

Why it matters now

EPSS 0.00604 49th percentileScored 2026-11-07
Fix Fixed Mendix SAML Module (Siemens): V2.1.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
SiemensMendix SAML Modulebefore V2.1.2V2.1.2Patch availableCNA
  • Mendix SAML Module VendorSiemens Affected before V2.1.2 Fixed in V2.1.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mendix:saml:*:*:*:*:*:*:*:*before 2.1.2VulnerableMendix
  • cpe:2.3:a:mendix:saml:*:*:*:*:*:*:*:* Versions before 2.1.2 Vulnerable ·Mendix

Remediation

  • Fix · CNA Mendix SAML Module (Siemens) Fixed in V2.1.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-33712
  2. 2026-10-03 Alias added: GHSA-5xc3-hrwr-2p8h

References

  • TI-2026-20057 Authentication bypass in Fortinet FortiWeb KEVCVSS 3.1CRITICAL 9.4
  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-18911 Heap-based buffer overflow in Fortinet FortiSwitchManager KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-07142 Code injection in Spring Framework KEVCVSS 3.1CRITICAL 9.8
  • TI-2021-19919 Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints KEVCVSS 3.1CRITICAL 10.0
See all 2487 →

Sources