CSRF Bypass in Proxy Server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
A cross-site request forgery (CSRF) vulnerability has been reported to affect QNAP device running Proxy Server. If exploited, this vulnerability allows remote attackers to inject malicious code. We have already fixed this vulnerability in the following versions of Proxy Server: QTS 4.5.x: Proxy Server 1.4.2 ( 2021/12/30 ) and later QuTS hero h5.0.0: Proxy Server 1.4.3 ( 2022/01/18 ) and later QuTScloud c4.5.6: Proxy Server 1.4.2 ( 2021/12/30 ) and later
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| QNAP | Proxy Server | before 1.4.2 ( 2021/12/30 ) | 1.4.2 ( 2021/12/30 ) | Patch available | CNA |
| QNAP | Proxy Server | before 1.4.3 ( 2022/01/18 ) | 1.4.3 ( 2022/01/18 ) | Patch available | CNA |
| QNAP | Proxy Server | before 1.4.2 ( 2021/12/30 ) | 1.4.2 ( 2021/12/30 ) | Patch available | CNA |
- Proxy Server VendorQNAP Affected before 1.4.2 ( 2021/12/30 ) Fixed in 1.4.2 ( 2021/12/30 ) Patch available CNA
- Proxy Server VendorQNAP Affected before 1.4.3 ( 2022/01/18 ) Fixed in 1.4.3 ( 2022/01/18 ) Patch available CNA
- Proxy Server VendorQNAP Affected before 1.4.2 ( 2021/12/30 ) Fixed in 1.4.2 ( 2021/12/30 ) Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qnap:nas_proxy_server:*:*:*:*:*:*:*:* | 1.4.0 to before 1.4.2 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:qts:*:*:*:*:*:*:*:* | 4.5.1 – 4.5.4.2012 | Running on | QNAP |
| cpe:2.3:a:qnap:nas_proxy_server:*:*:*:*:*:*:*:* | 1.4.0 to before 1.4.3 | Vulnerable | QNAP |
| cpe:2.3:o:qnap:quts_hero:h5.0.0:*:*:*:*:*:*:* | h5.0.0 | Running on | QNAP |
| cpe:2.3:o:qnap:qutscloud:c4.5.6:-:*:*:*:*:*:* | c4.5.6 | Running on | QNAP |
- cpe:2.3:a:qnap:nas_proxy_server:*:*:*:*:*:*:*:* Versions 1.4.0 to before 1.4.2 Vulnerable ·QNAP
- cpe:2.3:o:qnap:qts:*:*:*:*:*:*:*:* Versions 4.5.1 – 4.5.4.2012 Running on ·QNAP
- cpe:2.3:a:qnap:nas_proxy_server:*:*:*:*:*:*:*:* Versions 1.4.0 to before 1.4.3 Vulnerable ·QNAP
- cpe:2.3:o:qnap:quts_hero:h5.0.0:*:*:*:*:*:*:* Versions h5.0.0 Running on ·QNAP
- cpe:2.3:o:qnap:qutscloud:c4.5.6:-:*:*:*:*:*:* Versions c4.5.6 Running on ·QNAP
Remediation
- Fix · CNA Proxy Server (QNAP Systems Inc.) Fixed in 1.4.2 ( 2021/12/30 )
- Fix · CNA Proxy Server (QNAP Systems Inc.) Fixed in 1.4.3 ( 2022/01/18 )
- Fix · CNA Proxy Server (QNAP Systems Inc.) Fixed in 1.4.2 ( 2021/12/30 )
Timeline
- 2026-10-02 Threatist record created from CVE-2021-34360
- 2026-10-03 Alias added: GHSA-fx2r-gh7f-x6hf
References
More QNAP Nas Proxy Server vulnerabilities
- TI-2017-05273 QNAP NAS application Proxy Server through version 1.2.0 allows remote attackers to run… CVSS 3.0CRITICAL 9.8
- TI-2017-05271 QNAP NAS application Proxy Server through version 1.2.0 does not utilize CSRF protections. CVSS 3.0HIGH 8.8
- TI-2021-13398 Stored XSS Vulnerability in Proxy Server CVSS 3.1MEDIUM 6.9
- TI-2017-05272 Cross-site scripting (XSS) vulnerability in QNAP NAS application Proxy Server through… CVSS 3.0MEDIUM 6.1
- TI-2021-13400 Reflected XSS Vulnerability in Proxy Server CVSS 3.1MEDIUM 6.1
- TI-2017-05275 QNAP NAS application Proxy Server through version 1.2.0 does not authenticate requests… CVSS 3.0MEDIUM 5.3
Sources
- CVE-2021-34360 · CVE Program
- CVE-2021-34360 · NVD
- FIRST EPSS
- GHSA-fx2r-gh7f-x6hf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences