Arbitrary command execution in Keybase Client for Windows
Priority LOW 34Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A vulnerability was discovered in the Keybase Client for Windows before version 5.6.0 when a user executed the "keybase git lfs-config" command on the command-line. In versions prior to 5.6.0, a malicious actor with write access to a user\'s Git repository could leverage this vulnerability to potentially execute arbitrary Windows commands on a user\'s local system.
Why it matters now
EPSS 0.00247 16th percentileScored 2026-11-07
Fix Fixed Keybase Client for Windows (Zoom Video Communications Inc): 5.6.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Zoom Video Communications, Inc. | Keybase Client for Windows | before 5.6.0 | 5.6.0 | Patch available | CNA |
- Keybase Client for Windows VendorZoom Video Communications, Inc. Affected before 5.6.0 Fixed in 5.6.0 Patch available CNA
Remediation
- Fix · CNA Keybase Client for Windows (Zoom Video Communications Inc) Fixed in 5.6.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-34426
- 2026-10-03 Alias added: GHSA-h72j-pmww-phww
References
More Zoom Video Communications, Inc. vulnerabilities
- TI-2026-18340 Zoom Node Deployments - Command Injection CVSS 3.1CRITICAL 9.9
- TI-2017-11048 The ZoomLauncher binary in the Zoom client for Linux before 2.0.115900.1201 does not… CVSS 3.1HIGH 8.8
- TI-2017-11047 Stack-based buffer overflow in the ZoomLauncher binary in the Zoom client for Linux… CVSS 3.1HIGH 8.8
- TI-2020-04976 Path traversal in Zoom CVSS 3.1CRITICAL 9.8
- TI-2026-38498 Zoom Workplace VDI Plugin for Windows - Improper Input Validation CVSS 3.1CRITICAL 9.8
- TI-2021-13217 Improper certificate validation in Zoom Client for Meetings for Windows CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-34426 · CVE Program
- CVE-2021-34426 · NVD
- FIRST EPSS
- GHSA-h72j-pmww-phww · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences