CODESYS V2 runtime: unauthenticated invalid requests may result in denial-of-service
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In CODESYS V2 Runtime Toolkit 32 Bit full and PLCWinNT prior to versions V2.4.7.56 unauthenticated crafted invalid requests may result in several denial-of-service conditions. Running PLC programs may be stopped, memory may be leaked, or further communication clients may be blocked from accessing the PLC.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| CODESYS | CODESYS V2 | Runtime Toolkit 32 bit full to before V2.4.7.56; PLCWinNT to before V2.4.7.56 | V2.4.7.56 | Patch available | CNA |
- CODESYS V2 VendorCODESYS Affected Runtime Toolkit 32 bit full to before V2.4.7.56; PLCWinNT to before V2.4.7.56 Fixed in V2.4.7.56 Patch available CNA
CPE configurations NVD · 28
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:wago:750-8202_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8202:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
| cpe:2.3:o:wago:750-8203_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8203:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
| cpe:2.3:o:wago:750-8204_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8204:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
| cpe:2.3:o:wago:750-8206_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8206:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
| cpe:2.3:o:wago:750-8207_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8207:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
- cpe:2.3:o:wago:750-8202_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8202:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
- cpe:2.3:o:wago:750-8203_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8203:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
- cpe:2.3:o:wago:750-8204_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8204:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
- cpe:2.3:o:wago:750-8206_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8206:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
- cpe:2.3:o:wago:750-8207_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8207:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
Show 18 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:wago:750-8208_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8208:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
| cpe:2.3:o:wago:750-8210_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8210:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
| cpe:2.3:o:wago:750-8211_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8211:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
| cpe:2.3:o:wago:750-8212_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8212:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
| cpe:2.3:o:wago:750-8213_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8213:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
| cpe:2.3:o:wago:750-8214_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8214:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
| cpe:2.3:o:wago:750-8216_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8216:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
| cpe:2.3:o:wago:750-8217_firmware:*:*:*:*:*:*:*:* | before fw20 | Vulnerable | WAGO |
| cpe:2.3:h:wago:750-8217:-:*:*:*:*:*:*:* | not specified by NVD | Running on | WAGO |
| cpe:2.3:a:codesys:plcwinnt:*:*:*:*:*:*:*:* | before 2.4.7.56 | Vulnerable | CODESYS |
| cpe:2.3:a:codesys:runtime_toolkit:*:*:*:*:*:*:x86:* | before 2.4.7.56 | Vulnerable | CODESYS |
- cpe:2.3:o:wago:750-8208_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8208:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
- cpe:2.3:o:wago:750-8210_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8210:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
- cpe:2.3:o:wago:750-8211_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8211:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
- cpe:2.3:o:wago:750-8212_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8212:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
- cpe:2.3:o:wago:750-8213_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8213:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
- cpe:2.3:o:wago:750-8214_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8214:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
- cpe:2.3:o:wago:750-8216_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8216:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
- cpe:2.3:o:wago:750-8217_firmware:*:*:*:*:*:*:*:* Versions before fw20 Vulnerable ·WAGO
- cpe:2.3:h:wago:750-8217:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·WAGO
- cpe:2.3:a:codesys:plcwinnt:*:*:*:*:*:*:*:* Versions before 2.4.7.56 Vulnerable ·CODESYS
- cpe:2.3:a:codesys:runtime_toolkit:*:*:*:*:*:*:x86:* Versions before 2.4.7.56 Vulnerable ·CODESYS
Remediation
- Fix · CNA CODESYS V2 (CODESYS) Fixed in V2.4.7.56
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
CODESYS V2 V2.4.7.56
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2021-13613 CODESYS V2 runtime: out-of-bounds read or write access may result in denial-of-servicePriority LOW 37
- TI-2021-13614 CODESYS V2 runtime: Access of Uninitialized Pointer may result in denial-of-servicePriority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2021-34593
- 2026-10-03 Alias added: GHSA-mp42-p5v3-r5p6
References
Exploit 2
More CODESYS Plcwinnt vulnerabilities
- TI-2022-13698 Insecure default settings in CODESYS Runtime Toolkit 32 bit full and CODESYS PLCWinNT CVSS 3.1CRITICAL 9.8
- TI-2021-10734 CODESYS V2 runtime system before 2.4.7.55 has Improper Input Validation. CVSS 3.1HIGH 7.5
- TI-2021-10725 CODESYS V2 runtime system SP before 2.4.7.55 has a Heap-based Buffer Overflow. CVSS 3.1HIGH 7.5
- TI-2022-13872 CODESYS Runtime System prone to heap based buffer overflow CVSS 3.1HIGH 8.8
- TI-2022-13878 CODESYS runtime system prone to directory acces CVSS 3.1HIGH 8.8
- TI-2022-13873 CODESYS runtime system prone to denial of service due to Unexpected Sign Extension CVSS 3.1HIGH 8.8
Sources
- CVE-2021-34593 · CVE Program
- CVE-2021-34593 · NVD
- FIRST EPSS
- GHSA-mp42-p5v3-r5p6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences