Read the docs
TI-2021-14201 Aliases CVE-2021-35440GHSA-254j-mmc5-qhpx

Smashing 1.3.4 is vulnerable to Cross Site Scripting (XSS).

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Smashing 1.3.4 is vulnerable to Cross Site Scripting (XSS). A URL for a widget can be crafted and used to execute JavaScript on the victim's computer. The JavaScript code can then steal data available in the session/cookies depending on the user environment (e.g. if re-using internal URL's for deploying, or cookies that are very permissive) private information may be retrieved by the attacker.

Why it matters now

EPSS 0.00995 62nd percentileScored 2026-11-07
Fix Fixed smashing (RubyGems): 1.3.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—smashing (RubyGems)before 1.3.51.3.5Patch availableGHSA-254j-mmc5-qhpx
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • smashing (RubyGems) Vendor— Affected before 1.3.5 Fixed in 1.3.5 Patch available GHSA-254j-mmc5-qhpx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:smashing_project:smashing:1.3.4:*:*:*:*:*:*:*1.3.4VulnerableSmashing Project
  • cpe:2.3:a:smashing_project:smashing:1.3.4:*:*:*:*:*:*:* Versions 1.3.4 Vulnerable ·Smashing Project

Remediation

  • Fix · GHSA-254j-mmc5-qhpx smashing (RubyGems) Fixed in 1.3.5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-35440
  2. 2026-10-03 Alias added: GHSA-254j-mmc5-qhpx

References

Sources