Read the docs
TI-2021-14471 Aliases CVE-2021-36021GHSA-4g27-q2w9-m8m8

Magento Commerce CMS Page Improper Input Validation Could Lead To Remote Code Execution

Priority LOW 38CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Magento versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an Improper input validation vulnerability within the CMS page scheduled update feature. An authenticated attacker with administrative privilege could leverage this vulnerability to achieve remote code execution on the system.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02012 81st percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.3.7-p1, 2.4.2-p2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AdobeAdobe Commerceup to 2.3.7—No fix listedCNA
—magento/project-community-edition (Packagist)up to 2.0.2—No fix listedGHSA-4g27-q2w9-m8m8
—magento/community-edition (Packagist)before 2.3.7-p12.3.7-p1Patch availableGHSA-4g27-q2w9-m8m8
—magento/community-edition (Packagist)——No fix listedGHSA-4g27-q2w9-m8m8
—magento/community-edition (Packagist)2.4.2-p1 to before 2.4.2-p22.4.2-p2Patch availableGHSA-4g27-q2w9-m8m8
—magento/community-edition (Packagist)——No fix listedGHSA-4g27-q2w9-m8m8
  • Adobe Commerce VendorAdobe Affected up to 2.3.7 Fixed in — No fix listed CNA
  • magento/project-community-edition (Packagist) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-4g27-q2w9-m8m8
  • magento/community-edition (Packagist) Vendor— Affected before 2.3.7-p1 Fixed in 2.3.7-p1 Patch available GHSA-4g27-q2w9-m8m8
  • magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-4g27-q2w9-m8m8
  • magento/community-edition (Packagist) Vendor— Affected 2.4.2-p1 to before 2.4.2-p2 Fixed in 2.4.2-p2 Patch available GHSA-4g27-q2w9-m8m8
  • magento/community-edition (Packagist) Vendor— Affected — Fixed in — No fix listed GHSA-4g27-q2w9-m8m8

CPE configurations NVD · 10

CPEVersionsRoleVendor
cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:*before 2.3.7VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*before 2.3.7VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:*2.4.0 to before 2.4.2VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*2.4.0 to before 2.4.2VulnerableMagento
cpe:2.3:a:magento:magento:2.3.7:-:*:*:commerce:*:*:*2.3.7VulnerableMagento
cpe:2.3:a:magento:magento:2.3.7:-:*:*:open_source:*:*:*2.3.7VulnerableMagento
cpe:2.3:a:magento:magento:2.4.2:-:*:*:commerce:*:*:*2.4.2VulnerableMagento
cpe:2.3:a:magento:magento:2.4.2:-:*:*:open_source:*:*:*2.4.2VulnerableMagento
cpe:2.3:a:magento:magento:2.4.2:p1:*:*:commerce:*:*:*2.4.2 p1VulnerableMagento
cpe:2.3:a:magento:magento:2.4.2:p1:*:*:open_source:*:*:*2.4.2 p1VulnerableMagento
  • cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions before 2.3.7 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions before 2.3.7 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.4.0 to before 2.4.2 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.4.0 to before 2.4.2 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.3.7:-:*:*:commerce:*:*:* Versions 2.3.7 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.3.7:-:*:*:open_source:*:*:* Versions 2.3.7 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.4.2:-:*:*:commerce:*:*:* Versions 2.4.2 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.4.2:-:*:*:open_source:*:*:* Versions 2.4.2 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.4.2:p1:*:*:commerce:*:*:* Versions 2.4.2 p1 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.4.2:p1:*:*:open_source:*:*:* Versions 2.4.2 p1 Vulnerable ·Magento

Remediation

  • Fix · GHSA-4g27-q2w9-m8m8 magento/community-edition (Packagist) Fixed in 2.3.7-p1 Advisory →
  • Fix · GHSA-4g27-q2w9-m8m8 magento/community-edition (Packagist) Fixed in 2.4.2-p2 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Adobe Commerce — helpx.adobe.com/security/products/magento/apsb21-64.html

    3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW

    Other records, highest priority first

    • TI-2021-14473 Magento Commerce Widgets Update Layout XML Injection Vulnerability Could Lead To Remote Code ExecutionPriority MEDIUM 46
    • TI-2021-14486 Magento Commerce Media Gallery Upload Improper Access Control Could Lead To Remote Code ExecutionPriority LOW 38

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-36021
  2. 2026-10-03 Alias added: GHSA-4g27-q2w9-m8m8

References

  • TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-35688 ColdFusion | Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22) KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-34084 Adobe Experience Manager | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-19615 Analysis CVE-2023-29300 Bypass: Adobe ColdFusion Pre-Auth RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-13696 Adobe ColdFusion Deserialization of Untrusted Data Arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
See all 8046 →

Sources