Insecure TrustManager used in LDAP connections
Priority MEDIUM 45Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service. This affects versions <= 0.15.0. Users should update to version 0.16.0 which addresses this issue.
Why it matters now
EPSS 0.01302 70th percentileScored 2026-11-07
Fix Fixed org.apache.gobblin:gobblin-core (Maven): 0.16.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Gobblin | Apache Gobblin – 0.15.0 | — | No fix listed | CNA |
| — | org.apache.gobblin:gobblin-core (Maven) | before 0.16.0 | 0.16.0 | Patch available | GHSA-q5rx-8c2h-5q7j |
- Apache Gobblin VendorApache Affected Apache Gobblin – 0.15.0 Fixed in — No fix listed CNA
- org.apache.gobblin:gobblin-core (Maven) Vendor— Affected before 0.16.0 Fixed in 0.16.0 Patch available GHSA-q5rx-8c2h-5q7j
Remediation
- Fix · GHSA-q5rx-8c2h-5q7j org.apache.gobblin:gobblin-core (Maven) Fixed in 0.16.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-36152
- 2026-10-03 Alias added: GHSA-q5rx-8c2h-5q7j
References
More Apache Gobblin vulnerabilities
- TI-2021-14570 Local credentials disclosure in Apache Gobblin CVSS 3.1MEDIUM 5.5
Sources
- CVE-2021-36152 · CVE Program
- CVE-2021-36152 · NVD
- FIRST EPSS
- GHSA-q5rx-8c2h-5q7j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences