Insufficiently Protected Credentials in Metasys
Priority LOW 36CWE-522Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-522.
Summary
Under some circumstances an Insufficiently Protected Credentials vulnerability in Johnson Controls Metasys ADS/ADX/OAS 10 versions prior to 10.1.6 and 11 versions prior to 11.0.3 allows API calls to expose credentials in plain text.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0043 37th percentileScored 2026-11-07
Fix Fixed Metasys ADS/ADX/OAS (Johnson Controls): 10.1.6, 11.0.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Johnson Controls | Metasys ADS/ADX/OAS | All 10 versions to before 10.1.6; All 11 versions to before 11.0.3 | 10.1.6, 11.0.3 | Patch available | CNA |
- Metasys ADS/ADX/OAS VendorJohnson Controls Affected All 10 versions to before 10.1.6; All 11 versions to before 11.0.3 Fixed in 10.1.6, 11.0.3 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:johnsoncontrols:metasys_application_and_data_server:*:*:*:*:*:*:*:* | 10.0 to before 10.1.6; 11.0 to before 11.0.3 | Vulnerable | Johnson Controls |
| cpe:2.3:a:johnsoncontrols:metasys_extended_application_and_data_server:*:*:*:*:*:*:*:* | 10.0 to before 10.1.6; 11.0 to before 11.0.3 | Vulnerable | Johnson Controls |
| cpe:2.3:a:johnsoncontrols:metasys_open_application_server:*:*:*:*:*:*:*:* | 10.0 to before 10.1.6; 11.0 to before 11.0.3 | Vulnerable | Johnson Controls |
- cpe:2.3:a:johnsoncontrols:metasys_application_and_data_server:*:*:*:*:*:*:*:* Versions 10.0 to before 10.1.6; 11.0 to before 11.0.3 Vulnerable ·Johnson Controls
- cpe:2.3:a:johnsoncontrols:metasys_extended_application_and_data_server:*:*:*:*:*:*:*:* Versions 10.0 to before 10.1.6; 11.0 to before 11.0.3 Vulnerable ·Johnson Controls
- cpe:2.3:a:johnsoncontrols:metasys_open_application_server:*:*:*:*:*:*:*:* Versions 10.0 to before 10.1.6; 11.0 to before 11.0.3 Vulnerable ·Johnson Controls
Remediation
- Fix · CNA Metasys ADS/ADX/OAS (Johnson Controls) Fixed in 10.1.6, 11.0.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-36204
- 2026-10-03 Alias added: GHSA-4h8x-xvqq-f78f
References
More Johnson Controls Metasys Application And Data Server vulnerabilities
- TI-2021-14621 Metasys session token CVSS 3.1CRITICAL 9.8
- TI-2020-07260 Metasys Improper Restriction of XML External Entity Reference CVSS 3.1CRITICAL 9.1
- TI-2022-06298 Metasys Unverified Password Change CVSS 3.1HIGH 8.8
- TI-2021-14623 Metasys privilege management CVSS 3.1HIGH 8.8
- TI-2021-14618 Server-side request forgery in Johnson Controls Metasys CVSS 3.1HIGH 8.8
- TI-2022-06301 Cross-site scripting in Johnson Controls Metasys ADS/ADX/OAS server CVSS 3.1HIGH 8.7
Sources
- CVE-2021-36204 · CVE Program
- CVE-2021-36204 · NVD
- FIRST EPSS
- GHSA-4h8x-xvqq-f78f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences