Incorrect permission assignment in Dell VNX2
Priority LOW 29CWE-732Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
Dell VNX2 for File version 8.1.21.266 and earlier, contain a privilege escalation vulnerability. A local malicious admin may potentially exploit vulnerability and gain privileges.
Why it matters now
EPSS 0.00192 8th percentileScored 2026-11-07
Fix Fixed VNX2 (Dell): Version 8.1.21.303 (file) Version 5.33.021.5.303 (block)
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | VNX2 | before Version 8.1.21.303 (file) Version 5.33.021.5.303 (block) | Version 8.1.21.303 (file) Version 5.33.021.5.303 (block) | Patch available | CNA |
- VNX2 VendorDell Affected before Version 8.1.21.303 (file) Version 5.33.021.5.303 (block) Fixed in Version 8.1.21.303 (file) Version 5.33.021.5.303 (block) Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dell:emc_unity_operating_environment:*:*:*:*:*:*:*:* | up to 8.1.21.266 | Vulnerable | Dell |
| cpe:2.3:h:dell:vnx_vg10:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:vnx_vg50:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:vnx5200:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:vnx5400:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:vnx5600:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:vnx5800:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:vnx7600:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:vnx8000:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:h:dell:vnxe1600:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:a:dell:emc_unity_operating_environment:*:*:*:*:*:*:*:* Versions up to 8.1.21.266 Vulnerable ·Dell
- cpe:2.3:h:dell:vnx_vg10:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:vnx_vg50:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:vnx5200:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:vnx5400:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:vnx5600:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:vnx5800:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:vnx7600:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:vnx8000:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:h:dell:vnxe1600:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA VNX2 (Dell) Fixed in Version 8.1.21.303 (file) Version 5.33.021.5.303 (block)
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell VNX2 Version 8.1.21.303 (file) Version 5.33.021.5.303 (block)
4 records Highest priority Priority MEDIUM 2 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2021-14655 OS command injection in Dell VNX2Priority MEDIUM 47
- TI-2021-14656 Path traversal in Dell VNX2Priority MEDIUM 41
- TI-2021-14659 OS command injection in Dell VNX2Priority LOW 29
Timeline
- 2026-10-02 Threatist record created from CVE-2021-36290
- 2026-10-03 Alias added: GHSA-x2hv-v22j-8jpc
References
More Dell Emc Unity Operating Environment vulnerabilities
- TI-2021-14655 OS command injection in Dell VNX2 CVSS 3.1CRITICAL 9.8
- TI-2018-01098 XML external entity injection in Dell EMC Unisphere for VMAX Virtual Appliance, Dell EMC… CVSS 3.0CRITICAL 9.8
- TI-2021-14660 Dell VNX2 OE for File versions 8.1.21.266 and earlier, contain an authentication bypass… CVSS 3.1CRITICAL 9.8
- TI-2021-14656 Path traversal in Dell VNX2 CVSS 3.1CRITICAL 9.1
- TI-2021-14662 OS command injection in Dell VNX Control Station CVSS 3.1HIGH 7.2
- TI-2021-14661 OS command injection in Dell VNX Control Station CVSS 3.1HIGH 7.2
Sources
- CVE-2021-36290 · CVE Program
- CVE-2021-36290 · NVD
- FIRST EPSS
- GHSA-x2hv-v22j-8jpc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences