Improper input validation in Dell Networking X-Series
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Dell Networking X-Series firmware versions prior to 3.0.1.8 contain a host header injection vulnerability. A remote unauthenticated attacker may potentially exploit this vulnerability by injecting arbitrary host header values to poison the web-cache or trigger redirections.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | Networking X-Series | before 3.0.1.9 | 3.0.1.9 | Patch available | CNA |
- Networking X-Series VendorDell Affected before 3.0.1.9 Fixed in 3.0.1.9 Patch available CNA
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:x1008p_firmware:*:*:*:*:*:*:*:* | before 3.0.1.8 | Vulnerable | Dell |
| cpe:2.3:h:dell:x1008p:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:x1018p_firmware:*:*:*:*:*:*:*:* | before 3.0.1.8 | Vulnerable | Dell |
| cpe:2.3:h:dell:x1018p:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:x1026p_firmware:*:*:*:*:*:*:*:* | before 3.0.1.8 | Vulnerable | Dell |
| cpe:2.3:h:dell:x1026p:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:x1052p_firmware:*:*:*:*:*:*:*:* | before 3.0.1.8 | Vulnerable | Dell |
| cpe:2.3:h:dell:x1052p:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:x4012_firmware:*:*:*:*:*:*:*:* | before 3.0.1.8 | Vulnerable | Dell |
| cpe:2.3:h:dell:x4012:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:x1008p_firmware:*:*:*:*:*:*:*:* Versions before 3.0.1.8 Vulnerable ·Dell
- cpe:2.3:h:dell:x1008p:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:x1018p_firmware:*:*:*:*:*:*:*:* Versions before 3.0.1.8 Vulnerable ·Dell
- cpe:2.3:h:dell:x1018p:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:x1026p_firmware:*:*:*:*:*:*:*:* Versions before 3.0.1.8 Vulnerable ·Dell
- cpe:2.3:h:dell:x1026p:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:x1052p_firmware:*:*:*:*:*:*:*:* Versions before 3.0.1.8 Vulnerable ·Dell
- cpe:2.3:h:dell:x1052p:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:x4012_firmware:*:*:*:*:*:*:*:* Versions before 3.0.1.8 Vulnerable ·Dell
- cpe:2.3:h:dell:x4012:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:x1008_firmware:*:*:*:*:*:*:*:* | before 3.0.1.8 | Vulnerable | Dell |
| cpe:2.3:h:dell:x1008:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:x1018_firmware:*:*:*:*:*:*:*:* | before 3.0.1.8 | Vulnerable | Dell |
| cpe:2.3:h:dell:x1018:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:x1026_firmware:*:*:*:*:*:*:*:* | before 3.0.1.8 | Vulnerable | Dell |
| cpe:2.3:h:dell:x1026:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:x1052_firmware:*:*:*:*:*:*:*:* | before 3.0.1.8 | Vulnerable | Dell |
| cpe:2.3:h:dell:x1052:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:x1008_firmware:*:*:*:*:*:*:*:* Versions before 3.0.1.8 Vulnerable ·Dell
- cpe:2.3:h:dell:x1008:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:x1018_firmware:*:*:*:*:*:*:*:* Versions before 3.0.1.8 Vulnerable ·Dell
- cpe:2.3:h:dell:x1018:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:x1026_firmware:*:*:*:*:*:*:*:* Versions before 3.0.1.8 Vulnerable ·Dell
- cpe:2.3:h:dell:x1026:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:x1052_firmware:*:*:*:*:*:*:*:* Versions before 3.0.1.8 Vulnerable ·Dell
- cpe:2.3:h:dell:x1052:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA Networking X-Series (Dell) Fixed in 3.0.1.9
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell Networking X-Series 3.0.1.9
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2021-14684 Dell Networking X-Series firmware versions prior to 3.0.1.8 contain an authentication…Priority MEDIUM 44
- TI-2021-14685 Improper input validation in Dell Networking X-SeriesPriority LOW 35
Timeline
- 2026-10-02 Threatist record created from CVE-2021-36322
- 2026-10-03 Alias added: GHSA-g25f-q2fw-c4f4
References
More Dell X1008 Firmware vulnerabilities
- TI-2021-14684 Dell Networking X-Series firmware versions prior to 3.0.1.8 contain an authentication… CVSS 3.1CRITICAL 9.8
- TI-2021-04599 Dell EMC Networking X-Series firmware versions prior to 3.0.1.8 and Dell EMC PowerEdge… CVSS 3.1CRITICAL 9.8
- TI-2021-14685 Improper input validation in Dell Networking X-Series CVSS 3.1HIGH 7.5
Sources
- CVE-2021-36322 · CVE Program
- CVE-2021-36322 · NVD
- FIRST EPSS
- GHSA-g25f-q2fw-c4f4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences