Improper input validation in Dell CloudLink
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Dell EMC CloudLink 7.1 and all prior versions contain an Improper Input Validation Vulnerability. A remote low privileged attacker, may potentially exploit this vulnerability, leading to execution of arbitrary files on the server
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA CloudLink (Dell) Fixed in 7.1.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell CloudLink 7.1.1
7 records Highest priority Priority MEDIUM 4 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2021-14678 Dell EMC CloudLink 7.1 and all prior versions contain an Arbitrary File Creation…Priority MEDIUM 44
- TI-2021-14677 Injection in Dell CloudLinkPriority MEDIUM 43
- TI-2021-14676 Dell EMC CloudLink 7.1 and all prior versions contain a Hard-coded Password Vulnerability.Priority MEDIUM 41
Timeline
- 2026-10-02 Threatist record created from CVE-2021-36335
- 2026-10-03 Alias added: GHSA-8gcx-vcr8-7vhv
References
More Dell Emc Cloud Link vulnerabilities
- TI-2021-14678 Dell EMC CloudLink 7.1 and all prior versions contain an Arbitrary File Creation… CVSS 3.1CRITICAL 9.8
- TI-2021-14697 CSV injection in Dell CloudLink CVSS 3.1MEDIUM 6.8
- TI-2021-14695 Open redirect in Dell CloudLink CVSS 3.1MEDIUM 5.4
- TI-2021-14696 Buffer overflow in Dell CloudLink CVSS 3.1MEDIUM 5.5
Sources
- CVE-2021-36335 · CVE Program
- CVE-2021-36335 · NVD
- FIRST EPSS
- GHSA-8gcx-vcr8-7vhv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences