Deserialization of untrusted data in Dell Wyse Management Suite
Priority MEDIUM 45CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
Wyse Management Suite 3.3.1 and below versions contain a deserialization vulnerability that could allow an unauthenticated attacker to execute code on the affected system.
Why it matters now
EPSS 0.0171 77th percentileScored 2026-11-07
Fix Fixed Wyse Management Suite (Dell): 3.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Wyse Management Suite (Dell) Fixed in 3.5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell Wyse Management Suite 3.5
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2021-14700 Dell Wyse Management Suite version 3.3.1 and prior support insecure Transport Security…Priority LOW 33
Timeline
- 2026-10-02 Threatist record created from CVE-2021-36336
- 2026-10-03 Alias added: GHSA-mhfc-h92x-3f8m
References
More Dell Wyse Management Suite vulnerabilities
- TI-2026-56104 Unrestricted file upload in Dell Wyse Management Suite CVSS 3.1CRITICAL 9.8
- TI-2026-56103 Unrestricted file upload in Dell Wyse Management Suite CVSS 3.1CRITICAL 9.8
- TI-2026-56100 Unrestricted file upload in Dell Wyse Management Suite CVSS 3.1CRITICAL 9.8
- TI-2026-29748 Dell Wyse Management Suite, versions prior to WMS 5.5 HF1, contain an Acceptance of… CVSS 3.1CRITICAL 9.8
- TI-2026-56102 Missing authentication in Dell Wyse Management Suite CVSS 3.1CRITICAL 9.1
- TI-2025-24887 Dell Wyse Management Suite, versions prior to WMS 5.2, contain an Absolute Path Traversal… CVSS 3.1HIGH 8.2
Sources
- CVE-2021-36336 · CVE Program
- CVE-2021-36336 · NVD
- FIRST EPSS
- GHSA-mhfc-h92x-3f8m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences