Deleting PRTBs associated to a group doesn't cause deletion of corresponding RoleBindings
Priority MEDIUM 40CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
a Improper Access Control vulnerability in SUSE Rancher allows users to keep privileges that should have been revoked. This issue affects: SUSE Rancher Rancher versions prior to 2.4.18; Rancher versions prior to 2.5.12; Rancher versions prior to 2.6.3.
Why it matters now
EPSS 0.0097 62nd percentileScored 2026-11-07
Fix Fixed Rancher (SUSE): 2.4.18, 2.5.12, 2.6.3github.com/rancher/rancher (Go): 2.4.18, 2.5.12, 2.6.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | Rancher | Rancher to before 2.4.18 | 2.4.18 | Patch available | CNA |
| SUSE | Rancher | Rancher to before 2.5.12 | 2.5.12 | Patch available | CNA |
| SUSE | Rancher | Rancher to before 2.6.3 | 2.6.3 | Patch available | CNA |
| — | github.com/rancher/rancher (Go) | before 2.4.18 | 2.4.18 | Patch available | GHSA-28g7-896h-695v |
| — | github.com/rancher/rancher (Go) | 2.5.0 to before 2.5.12 | 2.5.12 | Patch available | GHSA-28g7-896h-695v |
| — | github.com/rancher/rancher (Go) | 2.6.0 to before 2.6.3 | 2.6.3 | Patch available | GHSA-28g7-896h-695v |
- Rancher VendorSUSE Affected Rancher to before 2.4.18 Fixed in 2.4.18 Patch available CNA
- Rancher VendorSUSE Affected Rancher to before 2.5.12 Fixed in 2.5.12 Patch available CNA
- Rancher VendorSUSE Affected Rancher to before 2.6.3 Fixed in 2.6.3 Patch available CNA
- github.com/rancher/rancher (Go) Vendor— Affected before 2.4.18 Fixed in 2.4.18 Patch available GHSA-28g7-896h-695v
- github.com/rancher/rancher (Go) Vendor— Affected 2.5.0 to before 2.5.12 Fixed in 2.5.12 Patch available GHSA-28g7-896h-695v
- github.com/rancher/rancher (Go) Vendor— Affected 2.6.0 to before 2.6.3 Fixed in 2.6.3 Patch available GHSA-28g7-896h-695v
Remediation
- Fix · CNA Rancher (SUSE) Fixed in 2.4.18
- Fix · CNA Rancher (SUSE) Fixed in 2.5.12
- Fix · CNA Rancher (SUSE) Fixed in 2.6.3
- Fix · GHSA-28g7-896h-695v github.com/rancher/rancher (Go) Fixed in 2.4.18 Advisory →
- Fix · GHSA-28g7-896h-695v github.com/rancher/rancher (Go) Fixed in 2.5.12 Advisory →
- Fix · GHSA-28g7-896h-695v github.com/rancher/rancher (Go) Fixed in 2.6.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-36775
- 2026-10-03 Alias added: GHSA-28g7-896h-695v
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-36775 · CVE Program
- CVE-2021-36775 · NVD
- FIRST EPSS
- GHSA-28g7-896h-695v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences