Read the docs
TI-2021-15507 Aliases CVE-2021-37632

Deserialization of Untrusted Data in com.supermartijn642.configlib.ConfigSyncPacket

Priority LOW 39CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.

Summary

SuperMartijn642's Config Lib is a library used by a number of mods for the game Minecraft. The versions of SuperMartijn642's Config Lib between 1.0.4 and 1.0.8 are affected by a vulnerability and can be exploited on both servers and clients. Using SuperMartijn642's Config Lib, servers will send a packet to clients with the server's config values. In order to read `enum` values from the packet data, `ObjectInputStream#readObject` is used. `ObjectInputStream#readObject` will instantiate a class based on the input data. Since, the packet data is not validated before `ObjectInputStream#readObject` is called, an attacker can instantiate any class by sending a malicious packet. If a suitable class is found, the vulnerability can lead to a number of exploits, including remote code execution. Although the vulnerable packet is typically only send from server to client, it can theoretically also be send from client to server. This means both clients and servers running SuperMartijn642's Config Lib between 1.0.4 and 1.0.8 are vulnerable. The vulnerability has been patched in SuperMartijn642's Config lib 1.0.9. Both, players and server owners, should update to 1.0.9 or higher.

Why it matters now

EPSS 0.01678 77th percentileScored 2026-11-07
Fix Fixed SuperMartijn642sConfigLib (SuperMartijn642): 1.0.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
SuperMartijn642SuperMartijn642sConfigLib1.0.4 to before 1.0.81.0.8Patch availableCNA
  • SuperMartijn642sConfigLib VendorSuperMartijn642 Affected 1.0.4 to before 1.0.8 Fixed in 1.0.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:config_lib_project:config_lib:*:*:*:*:*:*:*:*1.0.4 to before 1.0.9VulnerableConfig Lib Project
  • cpe:2.3:a:config_lib_project:config_lib:*:*:*:*:*:*:*:* Versions 1.0.4 to before 1.0.9 Vulnerable ·Config Lib Project

Remediation

  • Fix · CNA SuperMartijn642sConfigLib (SuperMartijn642) Fixed in 1.0.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-37632

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences