Arbitrary File Creation/Overwrite on Windows via insufficient relative path sanitization
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
The npm package "tar" (aka node-tar) before versions 4.4.18, 5.0.10, and 6.1.9 has an arbitrary file creation/overwrite and arbitrary code execution vulnerability. node-tar aims to guarantee that any file whose location would be outside of the extraction target directory is not extracted. This is, in part, accomplished by sanitizing absolute paths of entries within the archive, skipping archive entries that contain `..` path portions, and resolving the sanitized paths against the extraction target directory. This logic was insufficient on Windows systems when extracting tar files that contained a path that was not an absolute path, but specified a drive letter different from the extraction target, such as `C:some\path`. If the drive letter does not match the extraction target, for example `D:\extraction\dir`, then the result of `path.resolve(extractionDirectory, entryPath)` would resolve against the current working directory on the `C:` drive, rather than the extraction target directory. Additionally, a `..` portion of the path could occur immediately after the drive letter, such as `C:../foo`, and was not properly sanitized by the logic that checked for `..` within the normalized and split portions of the path. This only affects users of `node-tar` on Windows systems. These issues were addressed in releases 4.4.18, 5.0.10 and 6.1.9. The v3 branch of node-tar has been deprecated and did not receive patches for these issues. If you are still using a v3 release we recommend you update to a more recent version of node-tar. There is no reasonable way to work around this issue without performing the same path normalization procedures that node-tar now does. Users are encouraged to upgrade to the latest patched versions of node-tar, rather than attempt to sanitize paths themselves.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| npm | node-tar | before 4.4.18; 5.0.0 to before 5.0.10; 6.0.0 to before 6.1.9 | 4.4.18, 5.0.10, 6.1.9 | Patch available | CNA |
| — | tar (npm) | before 4.4.18 | 4.4.18 | Patch available | GHSA-5955-9wpr-37jh |
| — | tar (npm) | 5.0.0 to before 5.0.10 | 5.0.10 | Patch available | GHSA-5955-9wpr-37jh |
| — | tar (npm) | 6.0.0 to before 6.1.9 | 6.1.9 | Patch available | GHSA-5955-9wpr-37jh |
- node-tar Vendornpm Affected before 4.4.18; 5.0.0 to before 5.0.10; 6.0.0 to before 6.1.9 Fixed in 4.4.18, 5.0.10, 6.1.9 Patch available CNA
- tar (npm) Vendor— Affected before 4.4.18 Fixed in 4.4.18 Patch available GHSA-5955-9wpr-37jh
- tar (npm) Vendor— Affected 5.0.0 to before 5.0.10 Fixed in 5.0.10 Patch available GHSA-5955-9wpr-37jh
- tar (npm) Vendor— Affected 6.0.0 to before 6.1.9 Fixed in 6.1.9 Patch available GHSA-5955-9wpr-37jh
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:npmjs:tar:*:*:*:*:*:node.js:*:* | before 4.4.18; 5.0.0 to before 5.0.10; 6.0.0 to before 6.1.9 | Vulnerable | Npmjs |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
| cpe:2.3:a:oracle:graalvm:20.3.3:*:*:*:enterprise:*:*:* | 20.3.3 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:graalvm:21.2.0:*:*:*:enterprise:*:*:* | 21.2.0 | Vulnerable | Oracle |
| cpe:2.3:a:siemens:sinec_infrastructure_network_services:*:*:*:*:*:*:*:* | before 1.0.1.1 | Vulnerable | Siemens |
- cpe:2.3:a:npmjs:tar:*:*:*:*:*:node.js:*:* Versions before 4.4.18; 5.0.0 to before 5.0.10; 6.0.0 to before 6.1.9 Vulnerable ·Npmjs
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
- cpe:2.3:a:oracle:graalvm:20.3.3:*:*:*:enterprise:*:*:* Versions 20.3.3 Vulnerable ·Oracle
- cpe:2.3:a:oracle:graalvm:21.2.0:*:*:*:enterprise:*:*:* Versions 21.2.0 Vulnerable ·Oracle
- cpe:2.3:a:siemens:sinec_infrastructure_network_services:*:*:*:*:*:*:*:* Versions before 1.0.1.1 Vulnerable ·Siemens
Remediation
- Fix · CNA node-tar (npm) Fixed in 4.4.18, 5.0.10, 6.1.9
- Fix · GHSA-5955-9wpr-37jh tar (npm) Fixed in 4.4.18 Advisory →
- Fix · GHSA-5955-9wpr-37jh tar (npm) Fixed in 5.0.10 Advisory →
- Fix · GHSA-5955-9wpr-37jh tar (npm) Fixed in 6.1.9 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-37713
- 2026-10-03 Alias added: GHSA-5955-9wpr-37jh
References
Patch 3
Sources
- CVE-2021-37713 · CVE Program
- CVE-2021-37713 · NVD
- FIRST EPSS
- GHSA-5955-9wpr-37jh · GitHub Advisory Database · CC BY 4.0
- CVE-2021-37713 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences