Command injection in Aruba SD-WAN Software and Gateways; Aruba Operating System Software
Priority LOW 37CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-77.
Summary
A remote arbitrary command execution vulnerability was discovered in Aruba SD-WAN Software and Gateways; Aruba Operating System Software version(s): Prior to 8.6.0.4-2.2.0.4; Prior to 8.7.1.4, 8.6.0.9, 8.5.0.13, 8.3.0.16, 6.5.4.20, 6.4.4.25. Aruba has released patches for Aruba SD-WAN Software and Gateways and ArubaOS that address this security vulnerability.
Why it matters now
EPSS 0.02905 87th percentileScored 2026-11-07
Fix Fixed Aruba SD-WAN Software and Gateways; Aruba Operating System Software: 8.6.0.4-2.2.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Aruba SD-WAN Software and Gateways; Aruba Operating System Software | before 8.6.0.4-2.2.0.4; Prior to 8.7.1.4, 8.6.0.9, 8.5.0.13, 8.3.0.16, 6.5.4.20, 6.4.4.25 | 8.6.0.4-2.2.0.4 | Patch available | CNA |
- Aruba SD-WAN Software and Gateways; Aruba Operating System Software Vendor— Affected before 8.6.0.4-2.2.0.4; Prior to 8.7.1.4, 8.6.0.9, 8.5.0.13, 8.3.0.16, 6.5.4.20, 6.4.4.25 Fixed in 8.6.0.4-2.2.0.4 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:arubanetworks:sd-wan:*:*:*:*:*:*:*:* | 2.2.0.0 to before 2.2.0.4 | Vulnerable | Arubanetworks |
| cpe:2.3:o:arubanetworks:arubaos:*:*:*:*:*:*:*:* | 6.4.4.0 to before 6.4.4.25; 6.5.4.0 to before 6.5.4.20; 8.3.0.0 to before 8.3.0.16; 8.5.0.0 to before 8.5.0.13; 8.6.0.0 to before 8.6.0.9; 8.7.0.0 to before 8.7.1.4 | Vulnerable | Arubanetworks |
- cpe:2.3:a:arubanetworks:sd-wan:*:*:*:*:*:*:*:* Versions 2.2.0.0 to before 2.2.0.4 Vulnerable ·Arubanetworks
- cpe:2.3:o:arubanetworks:arubaos:*:*:*:*:*:*:*:* Versions 6.4.4.0 to before 6.4.4.25; 6.5.4.0 to before 6.5.4.20; 8.3.0.0 to before 8.3.0.16; 8.5.0.0 to before 8.5.0.13; 8.6.0.0 to before 8.6.0.9; 8.7.0.0 to before 8.7.1.4 Vulnerable ·Arubanetworks
Remediation
- Fix · CNA Aruba SD-WAN Software and Gateways; Aruba Operating System Software Fixed in 8.6.0.4-2.2.0.4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-37719
- 2026-10-03 Alias added: GHSA-xxgp-5c5m-vvhc
References
More Arubanetworks Arubaos vulnerabilities
- TI-2017-10594 Heap-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a… CVSS 3.1CRITICAL 9.8
- TI-2024-17386 Stack-based buffer overflow in Hewlett Packard Enterprise (HPE) Aruba Mobility Conductor… CVSS 3.1CRITICAL 9.8
- TI-2023-24417 Buffer overflow in Hewlett Packard Enterprise (HPE) Aruba Access Points: 100 Series; 103… CVSS 3.1CRITICAL 9.8
- TI-2023-24416 Buffer overflow in Hewlett Packard Enterprise (HPE) Aruba Access Points: 100 Series; 103… CVSS 3.1CRITICAL 9.8
- TI-2023-24415 Buffer overflow in Hewlett Packard Enterprise (HPE) Aruba Access Points: 100 Series; 103… CVSS 3.1CRITICAL 9.8
- TI-2023-18042 Unauthenticated Buffer Overflow Vulnerabilities in Services Accessed by the PAPI Protocol CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-37719 · CVE Program
- CVE-2021-37719 · NVD
- FIRST EPSS
- GHSA-xxgp-5c5m-vvhc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences