Reflected XSS in Kazoo Server
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A cross-site scripting (XSS) vulnerability has been reported to affect QNAP device running Kazoo Server. If exploited, this vulnerability allows remote attackers to inject malicious code. We have already fixed this vulnerability in the following versions of Kazoo Server: Kazoo Server 4.11.20 and later
Why it matters now
EPSS 0.00712 53rd percentileScored 2026-11-07
Fix Fixed Kazoo Server (Linn Products Limited): 4.11.20
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linn Products Limited | Kazoo Server | before 4.11.20 | 4.11.20 | Patch available | CNA |
- Kazoo Server VendorLinn Products Limited Affected before 4.11.20 Fixed in 4.11.20 Patch available CNA
Remediation
- Fix · CNA Kazoo Server (Linn Products Limited) Fixed in 4.11.20
Timeline
- 2026-10-02 Threatist record created from CVE-2021-38680
- 2026-10-03 Alias added: GHSA-jwgj-g8f9-jfg6
References
More QNAP Kazoo Server vulnerabilities
- TI-2021-16251 Improper Authentication in Kazoo Server CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-38680 · CVE Program
- CVE-2021-38680 · NVD
- FIRST EPSS
- GHSA-jwgj-g8f9-jfg6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences