Cross-site scripting via category name in Discourse
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Discourse is an open source platform for community discussion. In affected versions category names can be used for Cross-site scripting(XSS) attacks. This is mitigated by Discourse's default Content Security Policy and this vulnerability only affects sites which have modified or disabled or changed Discourse's default Content Security Policy have allowed for moderators to modify categories. This issue is patched in the latest stable, beta and tests-passed versions of Discourse. Users are advised to ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| discourse | discourse | before 2.7.8; 2.8.0.beta1 to before 2.8.0.beta4 | 2.7.8, 2.8.0.beta4 | Patch available | CNA |
- discourse Vendordiscourse Affected before 2.7.8; 2.8.0.beta1 to before 2.8.0.beta4 Fixed in 2.7.8, 2.8.0.beta4 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:* | before 2.7.8 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.8.0:beta1:*:*:*:*:*:* | 2.8.0 beta1 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.8.0:beta2:*:*:*:*:*:* | 2.8.0 beta2 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.8.0:beta3:*:*:*:*:*:* | 2.8.0 beta3 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.8.0:beta4:*:*:*:*:*:* | 2.8.0 beta4 | Vulnerable | discourse |
- cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:* Versions before 2.7.8 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.8.0:beta1:*:*:*:*:*:* Versions 2.8.0 beta1 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.8.0:beta2:*:*:*:*:*:* Versions 2.8.0 beta2 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.8.0:beta3:*:*:*:*:*:* Versions 2.8.0 beta3 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.8.0:beta4:*:*:*:*:*:* Versions 2.8.0 beta4 Vulnerable ·discourse
Remediation
- Fix · CNA discourse (discourse) Fixed in 2.7.8, 2.8.0.beta4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-39161
References
More Discourse vulnerabilities
- TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
- TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
- TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
- TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
- TI-2026-22278 Discourse leaks private topic title and post excerpt via user action API endpoint CVSS 4.0HIGH 8.7
- TI-2023-24152 Unauthenticated access to new private chat messages in Discourse CVSS 3.1HIGH 7.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences