Unlimited transforms allowed for signed nodes
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. Prior to version 3.1.0, a malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack. This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| node-saml | passport-saml | before 3.1.0 | 3.1.0 | Patch available | CNA |
| — | passport-saml (npm) | before 3.1.0 | 3.1.0 | Patch available | GHSA-5379-r78w-42h2 |
- passport-saml Vendornode-saml Affected before 3.1.0 Fixed in 3.1.0 Patch available CNA
- passport-saml (npm) Vendor— Affected before 3.1.0 Fixed in 3.1.0 Patch available GHSA-5379-r78w-42h2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:passport-saml_project:passport-saml:*:*:*:*:*:node.js:*:* | before 3.1.0 | Vulnerable | Passport-saml Project |
- cpe:2.3:a:passport-saml_project:passport-saml:*:*:*:*:*:node.js:*:* Versions before 3.1.0 Vulnerable ·Passport-saml Project
Remediation
- Fix · CNA passport-saml (node-saml) Fixed in 3.1.0
- Fix · GHSA-5379-r78w-42h2 passport-saml (npm) Fixed in 3.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-39171
- 2026-10-03 Alias added: GHSA-5379-r78w-42h2
References
Advisory 2
More node-saml vulnerabilities
- TI-2024-21829 XML signature verification bypass due improper verification of signature / signature spoofing CVSS 3.1CRITICAL 10.0
- TI-2025-21187 xml-crypto Vulnerable to XML Signature Verification Bypass via DigestValue Comment CVSS 4.0CRITICAL 9.3
- TI-2025-21186 xml-crypto Vulnerable to XML Signature Verification Bypass via Multiple SignedInfo References CVSS 4.0CRITICAL 9.3
- TI-2025-34225 Node-SAML Contains SAML Signature Verification Vulnerability CVSS 3.1CRITICAL 10.0
- TI-2025-34181 Node-SAML SAML Authentication Bypass CVSS 4.0CRITICAL 9.3
Sources
- CVE-2021-39171 · CVE Program
- CVE-2021-39171 · NVD
- FIRST EPSS
- GHSA-5379-r78w-42h2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences