Privilege escalation: all users can access Admin-level API keys
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure, Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200 and CWE-269.
Summary
Ghost is a Node.js content management system. An error in the implementation of the limits service between versions 4.0.0 and 4.9.4 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. This issue is patched in Ghost version 4.10.0. As a workaround, disable all non-Administrator accounts to prevent API access. It is highly recommended to regenerate all API keys after patching or applying the workaround.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| TryGhost | Ghost | 4.0.0 to before 4.10.0 | 4.10.0 | Patch available | CNA |
| — | ghost (npm) | 4.0.0 to before 4.10.0 | 4.10.0 | Patch available | GHSA-j5c2-hm46-wp5c |
- Ghost VendorTryGhost Affected 4.0.0 to before 4.10.0 Fixed in 4.10.0 Patch available CNA
- ghost (npm) Vendor— Affected 4.0.0 to before 4.10.0 Fixed in 4.10.0 Patch available GHSA-j5c2-hm46-wp5c
Remediation
- Fix · CNA Ghost (TryGhost) Fixed in 4.10.0
- Fix · GHSA-j5c2-hm46-wp5c ghost (npm) Fixed in 4.10.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-39192
- 2026-10-03 Alias added: GHSA-j5c2-hm46-wp5c
References
More TryGhost Ghost vulnerabilities
- TI-2026-21459 Ghost has a SQL Injection in its Content API CVSS 3.1CRITICAL 9.4
- TI-2022-10277 An arbitrary file upload vulnerability in the file upload module of Ghost v4.39.0 allows… CVSS 3.1CRITICAL 9.8
- TI-2024-22785 Ghost through 5.85.1 allows remote attackers to bypass an authentication rate-limit… CVSS 3.1CRITICAL 9.1
- TI-2023-14843 Ghost vulnerable to disclosure of private API fields CVSS 3.1HIGH 7.5
- TI-2025-09049 Ghost 6.0.6 - SSRF via oEmbed Bookmark CVSS 4.0MEDIUM 6.1
- TI-2023-20918 Arbitrary file read via symlinks in Ghost CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-39192 · CVE Program
- CVE-2021-39192 · NVD
- FIRST EPSS
- GHSA-j5c2-hm46-wp5c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences