Read the docs
TI-2021-16592 Aliases CVE-2021-39207GHSA-m87f-9fvv-2mgg

Deserialization of Untrusted Data in parlai

Priority MEDIUM 42CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

parlai is a framework for training and evaluating AI models on a variety of openly available dialogue datasets. In affected versions the package is vulnerable to YAML deserialization attack caused by unsafe loading which leads to Arbitary code execution. This security bug is patched by avoiding unsafe loader users should update to version above v1.1.0. If upgrading is not possible then users can change the Loader used to SafeLoader as a workaround. See commit 507d066ef432ea27d3e201da08009872a2f37725 for details.

Why it matters now

EPSS 0.01794 78th percentileScored 2026-11-07
Fix Fixed ParlAI (facebookresearch): 1.1.0parlai (PyPI): 1.1.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
facebookresearchParlAIbefore 1.1.01.1.0Patch availableCNA
—parlai (PyPI)before 1.1.01.1.0Patch availableGHSA-m87f-9fvv-2mgg
  • ParlAI Vendorfacebookresearch Affected before 1.1.0 Fixed in 1.1.0 Patch available CNA
  • parlai (PyPI) Vendor— Affected before 1.1.0 Fixed in 1.1.0 Patch available GHSA-m87f-9fvv-2mgg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:facebook:parlai:*:*:*:*:*:*:*:*before 1.1.0VulnerableMeta
  • cpe:2.3:a:facebook:parlai:*:*:*:*:*:*:*:* Versions before 1.1.0 Vulnerable ·Meta

Remediation

  • Fix · CNA ParlAI (facebookresearch) Fixed in 1.1.0
  • Fix · GHSA-m87f-9fvv-2mgg parlai (PyPI) Fixed in 1.1.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-39207
  2. 2026-10-03 Alias added: GHSA-m87f-9fvv-2mgg

References

  • TI-2026-48278 Hydra: hydra.utils.instantiate with untrusted config can lead to code execution CVSS 3.1HIGH 7.8

Sources