Issue when Configuring the ImageMagick Security Policy
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
ImageMagick is free software delivered as a ready-to-run binary distribution or as source code that you may use, copy, modify, and distribute in both open and proprietary applications. In affected versions and in certain cases, Postscript files could be read and written when specifically excluded by a `module` policy in `policy.xml`. ex. <policy domain="module" rights="none" pattern="PS" />. The issue has been resolved in ImageMagick 7.1.0-7 and in 6.9.12-22. Fortunately, in the wild, few users utilize the `module` policy and instead use the `coder` policy that is also our workaround recommendation: <policy domain="coder" rights="none" pattern="{PS,EPI,EPS,EPSF,EPSI}" />.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ImageMagick | ImageMagick | 7.0.0 to before 7.1.0-7; before 6.9.12-22 | 7.1.0-7, 6.9.12-22 | Patch available | CNA |
- ImageMagick VendorImageMagick Affected 7.0.0 to before 7.1.0-7; before 6.9.12-22 Fixed in 7.1.0-7, 6.9.12-22 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* | 6.9.12-0 to before 6.9.12-22; 7.1.0-0 to before 7.1.0-7 | Vulnerable | ImageMagick |
- cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* Versions 6.9.12-0 to before 6.9.12-22; 7.1.0-0 to before 7.1.0-7 Vulnerable ·ImageMagick
Remediation
- Fix · CNA ImageMagick (ImageMagick) Fixed in 7.1.0-7, 6.9.12-22
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
Timeline
- 2026-10-02 Threatist record created from CVE-2021-39212
References
Patch 2
More Imagemagick vulnerabilities
- TI-2016-03144 The (1) EPHEMERAL, (2) HTTPS, (3) MVG, (4) MSL, (5) TEXT, (6) SHOW, (7) WIN, and (8) PLT… KEVCVSS 3.1HIGH 8.4
- TI-2023-16996 Improper input validation in ImageMagick CVSS 3.1CRITICAL 9.8
- TI-2016-03148 The (1) HTTP and (2) FTP coders in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1… KEVCVSS 3.1MEDIUM 5.5
- TI-2016-03145 The EPHEMERAL coder in ImageMagick before 6.9.3-10 and 7.x before 7.0.1-1 allows remote… KEVCVSS 3.1MEDIUM 5.5
- TI-2025-35690 ImageMagick BlobStream Forward-Seek Under-Allocation CVSS 3.1CRITICAL 9.8
- TI-2025-33094 ImageMagick has Stack Buffer Overflow in image.c CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-39212 · CVE Program
- CVE-2021-39212 · NVD
- FIRST EPSS
- CVE-2021-39212 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences