Regular expression deinal of service in apprise
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is [here](https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359). The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove `apprise/plugins/NotifyIFTTT.py` to eliminate the service.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| caronc | apprise | before 0.9.5.1 | 0.9.5.1 | Patch available | CNA |
| — | apprise (PyPI) | before 0.9.5.1 | 0.9.5.1 | Patch available | GHSA-qhmp-h54x-38qr |
- apprise Vendorcaronc Affected before 0.9.5.1 Fixed in 0.9.5.1 Patch available CNA
- apprise (PyPI) Vendor— Affected before 0.9.5.1 Fixed in 0.9.5.1 Patch available GHSA-qhmp-h54x-38qr
Remediation
- Fix · CNA apprise (caronc) Fixed in 0.9.5.1
- Fix · GHSA-qhmp-h54x-38qr apprise (PyPI) Fixed in 0.9.5.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2021-39229
- 2026-10-03 Alias added: GHSA-qhmp-h54x-38qr
References
Advisory 2
More caronc vulnerabilities
- TI-2026-42332 Apprise forwards configured auth headers across cross-origin HTTP redirects CVSS 3.1LOW 3.1
Sources
- CVE-2021-39229 · CVE Program
- CVE-2021-39229 · NVD
- FIRST EPSS
- GHSA-qhmp-h54x-38qr · GitHub Advisory Database · CC BY 4.0
- CVE-2021-39229 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences